working set size regression, 2007-08-01

RESOLVED DUPLICATE of bug 390847

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 390847
10 years ago
10 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
There was a significant regression in "qm-pxp01 tp_Working Set_avg - 1.9" (see http://graphs.mozilla.org/ ) on 2007-08-01, due to bug 385393.  The working set size got significantly larger and started varying significantly more than it used to:

dataset,machine,branch,test,date
"9","qm-pxp01","1.9","tp_Working Set_avg",""
dataset,time,value,buildid,data
"9","1186013494","77920237.8939","200708011608","None"
"9","1186016583","77727106.2633","200708011658","None"
"9","1186019656","77384096.8141","200708011748","None"
"9","1186022747","78173427.8572","200708011838","None"
"9","1186025825","77268606.7524","200708011928","None"
"9","1186028901","77043602.2144","200708012018","None"
"9","1186038200","85071961.5569","200708012140","None"
"9","1186047522","84242745.2353","200708020039","None"
"9","1186050607","84919372","200708020219","None"
"9","1186053697","83554281.9462","200708020312","None"
"9","1186057780","81497293.2004","200708020402","None"
"9","1186060859","84901020.2371","200708020516","None"
Flags: blocking1.9?

Comment 1

10 years ago
Comparison of memory usage during run:

http://graphs.mozilla.org/dgraph.html#spst=range&spstart=0&spend=2049&bpst=Cursor&bpstart=0&bpend=2049&name=tp_Working%20Set&m1tid=10163&m1bl=0&m1avg=0&m2tid=12793&m2bl=0&m2avg=0

Seems to imply that our floor is moving up more rapidly during the run (e.g. might be a leak).

Comment 2

10 years ago
See bug 390847, comment 2.
Dup of bug 390847 ?

We have no evidence for a leak that I know of. We do have evidence that the patch for bug 385393 reduces memory pressure as measured by the heuristics that schedule garbage collection -- so we're doing fewer GCs. This will indeed result in steeper slope on RSS or any similar curve.

/be

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390847
You need to log in before you can comment on or make changes to this bug.