Closed Bug 391057 Opened 14 years ago Closed 2 years ago

Add ability to write to Mac OS X system Address Book

Categories

(MailNews Core :: Address Book, enhancement)

All
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kamikazow, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: helpwanted, Whiteboard: [gs])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.9a8pre) Gecko/2007080600 Camino/2.0a1pre (like Firefox/3.0a8pre)
Build Identifier: 

Now that Bug 203927 is fixed, adding write support to Mac OS X system Address Book for Thunderbird and SeaMonkey is the next step. :-)

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true
Of course this would be nice and the next logical step. But I'd prefer to just use the OS X address book app instead of TBs own implementation. So I fully agree with the following comment: https://bugzilla.mozilla.org/show_bug.cgi?id=203927#c146 Is there already a Bug / Feature Request for this one to sign on?
I would also like to add/modify/delete addresses directly inside the systems address book. But if we want to do that we need a seamless integration. I've no idea how mail.app is doing it's job. So if we want to go that way, we don't need the integrated address book at all?
Hardware: Macintosh → All
Depends on: 203927
(In reply to comment #2)
> I've no
> idea how mail.app is doing it's job. 

Do you mean the technical side or the UI side? For the latter one: The only places I can see, where Mail.app interacts with the address book are:


=== Reading access from Mail.app ===

-- Context menu entry of known addresses: "Open in address book"
-- Auto completion in address fields of mail composition windows (works now in TB)
-- Address book lookup window in composition windows (TB has similar functionality)

=== Access from Address Book to Mail.app === 

-- Context menu entry of E-Mail addresses: "Send Mail" (works with TB, if TB is set as default application for E-Mail)

=== Writing access from Mail.app ===
-- Context menu of header entries with E-Mail addresses: "Add to address book"
-- When receiving Mails with vCard attachments, clicking on those adds the contained entry to the address book (works in TB semi-automatically after defining address book as helper app for vcard entries -- could this be done automatically?)

If I didn't forget something, everything else (manual addition of E-Mail-addresses to the address book) is not done inside Mail.app but inside Address Book.app.

> So if we want to go that way, we don't
> need the integrated address book at all?

I think, that would be the smartest solution. TBs address book is a relict of Netscape 4s address book. While it makes sense on systems without a global address book, on Mac OS X, it lacks some features, the system address book has, e.g., integration with iSync.
For the technical side, the Address Book Programming Guide at http://developer.apple.com/documentation/UserExperience/Conceptual/AddressBook/ might be helpful.
Hi folks!

IMHO there hasn’t to be the opportunity to edit the addressbook entries in thunderbird (though that might be a additional benefit, because no other application has to be started).
But what I don’t like about the Apple Mail interface is, that I can only add the address to a *new* Contact. It would be much better, if one would be able to select "Add to new contact" or "Add to existing contact". In the end that most probably means Thunderbird must to be able to edit the Address Book.

Additionally I think the display of address book entries in Thunderbird has bugs.
Companies marked as such in the Address Book are displayed without any name (shouldn’t they be displayed with the organizations name at least?)

This leads to an other problem:
The form fields for the information differ between Thunderbird and Address Book. So maybe an update of the Address Book with an Thunderbird address entry isn’t that easy…
(In reply to comment #5)
> Additionally I think the display of address book entries in Thunderbird has
> bugs.
> Companies marked as such in the Address Book are displayed without any name
> (shouldn’t they be displayed with the organizations name at least?)

It's another issue and should be filed as a new bug. I'm preparing all the information at the moment and will file it tomorrow.
I think it would be nice to edit from Thunderbird, would make it complete.
The problem with implementing this (and the reason why I removed it from the patch in bug 203927) is that the data model for the Thunderbird address book doesn't map exactly to the data model of the OS X address book. The code for nsAbOSXCard::EditCardToDatabase in attachment 240331 [details] [diff] [review] could be a start if someone wants to fix this.
Product: Core → MailNews Core
Flags: wanted-thunderbird3+
This is a small patch I've just knocked up to implement the delete function for deleting cards from the OS X address book from within Thunderbird. It needs some error handling added (see comments in the patch).

Whilst only a small part of the task, this shows it can be done relatively simple, the hardest part will be translating the fields from thunderbird "speak" to OS X address book "speak" for new or modified cards. Given we already are able to translate the other way, this shouldn't be too difficult to work out.

I'm primarily working on other things at the moment, but if anyone else wishes to finish this patch for delete, and maybe even look at new/edit cards I'd welcome it, and if you need any help, feel free to ask.

The url in the url field gives the Apple reference documentation.
Keywords: helpwanted
Duplicate of this bug: 463404
Perhaps a quick-and-dirty (and easy?) solution to allowing users to edit their
Apple address book would be to put a button, menu item, and/or context menu in
the Thunderbird address book UI that loads apple's address book externally.
I just lost an easy convert to Thunderbird (my sister) because Thunderbird still cannot write to the Mac address book. (BTW: She could care less about global search!)

It would be great if this bug received the attention it deserves (Assigned to "nobody").

PS. I thought a lot of Mozilla developers used Macs. Don't you guys wish you could write to the Mac address book from Thunderbird?
I just started using TB3 and reading the OSX AB is great, but writing to it is a must have for total integration.
Duplicate of this bug: 536011
When the TB Address Book is in focus, the File menu has an option "Use Mac OS X Address Book".  To most (if not all) that will mean read and write -- i.e. full transparent integration.

Until full integration is implemented could I suggest a few interim solutions.

Maybe add some indicator that this read-only ?

Have another option "User Mac OS X Address Book to Modify Address Book Entries", which when selected, will invoke the "Address Book.app" to add, edit or delete "TB" addresses ??
When not selected, keep the current usage.

Can the TB Address book DB be extended to be more flexible to cater for other address book formats, so that features like OS X Address Book integration will be easier ???
http://getsatisfaction.com/mozilla_messaging/tags/bug_391057 is now the canonical topic for this issue.  and several other topics have been merged into it.
Whiteboard: [gs]
Blocks: tb-mac
Blocks: 482616
Fix?
Honestly it's kind of shocking that in more than 4 years since the release of 3.0 this has not been implemented...

Mac users who choose to use the OSX Address Book in Thunderbird (which sometimes you "have to", due to AB integration with other devices etc.) are having a highly sub-par experience, making Thunderbird use on OSX very unenjoyable. (e.g. dependant bugs like 482616 or contact groups not showing in the new mail contacts sidebar)

Is there any chance that this will ever be fixed? 
Is the importance of a bug only based on votes? Because you know, normal users doesn't visit the tracker every day...
> http://getsatisfaction.com/mozilla_messaging/tags/bug_391057 is now the
> canonical topic for this issue.  and several other topics have been merged
> into it.

The above getsatisfaction.com URL is a broken link.(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #16)
Full address book transparency seems unnecessary to me. Most people would use Thunderbird for email (and perhaps calendaring) exclusively. The functionality that would mean satisfactory, almost-complete OS integration would consist of:

- Adding a new contact: first name, last name, email address
- Adding an email address to an existing contact
- Modifying the email address(es) of an existing contact
- Removing an email address from an existing contact
- Modifying the name of an existing contact
- Changing a phone number for an existing contact

The last two aren't even really necessary (but convenient when someone sends a new phone number by email). And for more elaborate editing, a button could be added to "open this contact in the Apple address book".
should be possible with the addon CardBook (https://addons.mozilla.org/en-US/thunderbird/addon/cardbook/)
I support BvdG's suggestion from comment #20. The OS X addressbook is very convenient because it supports several synchronization options natively (CardDAV, Exchange, Gmail, etc), and using it avoids to duplicate the functionality in TB or an extension.

(Well full native opensource support for CardDAV in TB would be nice too, but for proprietary sync protocols I believe that it is quite relevant to leverage the resources of Apple.)
Duplicate of this bug: 1559526

(In reply to Philippe VIGNEAU from comment #21)

should be possible with the addon CardBook
(https://addons.mozilla.org/en-US/thunderbird/addon/cardbook/)

Can you tell me how this would work in practice? I'm trying to help a colleague who has a Mac with this, and I don't see any information on that plugin's page that tells me it supports writing to the Mac Address Book.

(In reply to Matijs van Zuijlen from comment #24)

(In reply to Philippe VIGNEAU from comment #21)

should be possible with the addon CardBook
(https://addons.mozilla.org/en-US/thunderbird/addon/cardbook/)

Can you tell me how this would work in practice? I'm trying to help a colleague who has a Mac with this, and I don't see any information on that plugin's page that tells me it supports writing to the Mac Address Book.

don't know why I came on this bug... what I surely meant is that CardBook may write on Apple address books by synchronizing them via iCloud...

I think this bug is wontfix per se, although the feature is desirable.

I think the way we will enable writing to mac address book is by us implementing CardDAV support (bug 546932) and shift mac address books over to access through the icloud CardDAV interface.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.