Last Comment Bug 391429 - Editor caret is hidden in XULRunner applications, but visible in Firefox
: Editor caret is hidden in XULRunner applications, but visible in Firefox
Status: VERIFIED FIXED
[dbaron-1.9:RpCc]
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: x86 All
: -- normal with 1 vote (vote)
: mozilla1.9beta1
Assigned To: Matt Crocker
:
: Makoto Kato [:m_kato]
Mentors:
: 387534 398909 400576 401648 415380 439501 (view as bug list)
Depends on:
Blocks: contenteditable 387534
  Show dependency treegraph
 
Reported: 2007-08-08 13:27 PDT by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2008-06-16 22:27 PDT (History)
25 users (show)
roc: blocking1.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to change from resource:/res to resource://gre/res. (18.58 KB, patch)
2007-10-25 11:34 PDT, Matt Crocker
peterv: review+
peterv: superreview+
mbeltzner: approvalM9+
mbeltzner: approval1.9+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2007-08-08 13:27:56 PDT
In any rich editing element (<editor> or <iframe> w/ designmode="on") the blinking caret is not visible. This only seems to happen in XULRunner applications, because when viewing the same content in Firefox trunk, the caret is visible.

The easiet example may be to use the WebRunner XUL application (http://wiki.mozilla.org/WebRunner - Mac version uses XR1.9a7pre) and launch GMail webapp. You can see the problem in the "Compose New Mail" screen with "Rich Editing" selected.

The same screen in Firefox does not show the problem - the caret is visible.

XUL Explorer, which uses an <editor> element, also has the problem when running with XR 1.9a7pre
Comment 1 philippe (part-time) 2007-08-08 18:22:45 PDT
I could be wrong, or way of base, but is this related to a very similar Camino bug: bug 387013 ?
Comment 2 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-08-19 18:08:34 PDT
Mark, I noticed over in bug 387013 that Camino's not packaging some new css files peterv added with the contentEditable checkin, and philippe reported that adding them seems to fix the caret bug.  Any chance XULRunner (WebRunner?) is missing 

res/contenteditable.css
res/designmode.css

too (wherever res/ lives in XULRunner; it's $APPNAME.app/Contents/MacOS/res/ in Camino and Mac Firefox)? 
Comment 3 Caio Tiago Oliveira (asrail) 2007-08-26 19:42:02 PDT
I believe it is due some missing point on the fix for bug 387534.
Comment 4 David Baron :dbaron: ⌚️UTC-8 2007-10-01 22:21:23 PDT
Is this an issue in a build you do yourself, or only in a packaged build (i.e., extracted from a zip/tar/installer)?
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2007-10-02 05:42:51 PDT
(In reply to comment #4)
> Is this an issue in a build you do yourself, or only in a packaged build (i.e.,
> extracted from a zip/tar/installer)?
> 

No, it occurs in the nightly Mozilla xulrunner builds (extracted from zip). Also, it occurs on all platforms.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2007-10-07 11:09:55 PDT
*** Bug 398909 has been marked as a duplicate of this bug. ***
Comment 7 jrintels 2007-10-17 07:10:00 PDT
This bug does not exist in version 0.5 on my computer.  Only version 0.7.  So I've downgraded back to 0.5.  
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2007-10-20 21:34:13 PDT
*** Bug 400576 has been marked as a duplicate of this bug. ***
Comment 9 Matt Crocker 2007-10-23 14:35:17 PDT
Smokey was on the right track.

In XULRunner, resource:/ is the app root, and resource:/gre/ is app/xulrunner/. In Firefox they both point to the same place.  The problem is that contenteditable.css and designmode.css are packaged in xulrunner/res/, but are referenced via resource:/res/.

I've confirmed this with XUL Explorer and the test-case from Bug 387534 by copying xulrunner/res/ into the app root.  

It seems to me the fix is to modify the editor to use resource:/gre/res/.  If I make a patch that does this is it likely to be accepted?

Also, may I dupe Bug 387534 with this bug?
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2007-10-23 16:11:20 PDT
(In reply to comment #9)
> Smokey was on the right track.
> 
> In XULRunner, resource:/ is the app root, and resource:/gre/ is app/xulrunner/.
> In Firefox they both point to the same place.  The problem is that
> contenteditable.css and designmode.css are packaged in xulrunner/res/, but are
> referenced via resource:/res/.
> 

Huh, I fixed a similar problem with the spellcheck dictionaries not working in XR apps.

> I've confirmed this with XUL Explorer and the test-case from Bug 387534 by
> copying xulrunner/res/ into the app root.  
> 
Great

> It seems to me the fix is to modify the editor to use resource:/gre/res/.  If I
> make a patch that does this is it likely to be accepted?
> 
> Also, may I dupe Bug 387534 with this bug?
> 
I suggest making the patch and marking bug 387534 a dupe. This bug is fairly critical for any XR apps using the editor and is marked blocking1.9 (whatever that means these days)

Thanks Matt
Comment 11 Georg Maaß 2007-10-24 00:28:18 PDT
I guess it really is what bug 387534 talks about
Comment 12 Matt Crocker 2007-10-25 11:31:50 PDT
*** Bug 387534 has been marked as a duplicate of this bug. ***
Comment 13 Matt Crocker 2007-10-25 11:34:21 PDT
Created attachment 286180 [details] [diff] [review]
Patch to change from resource:/res to resource://gre/res. 

Tested with XUL Explorer and the test case from Bug 387534.  Any volunteers to test Firefox/Composer/Camino?
Comment 14 Smokey Ardisson (offline for a while; not following bugs - do not email) 2007-10-25 11:54:08 PDT
Matt, everything continues to operate as expected in Camino with this patch (where everything = http://www.mozilla.org/editor/midasdemo )
Comment 15 Matt Crocker 2007-10-25 13:02:07 PDT
Great, thanks Smokey!
Comment 16 Matt Crocker 2007-10-25 13:03:52 PDT
Comment on attachment 286180 [details] [diff] [review]
Patch to change from resource:/res to resource://gre/res. 

Daniel, do you mind reviewing this?
Comment 17 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-25 14:11:50 PDT
Comment on attachment 286180 [details] [diff] [review]
Patch to change from resource:/res to resource://gre/res. 

Probably better to ask Peter for review, I don't think Daniel is doing a lot of reviewing.
Comment 18 Peter Van der Beken [:peterv] 2007-10-26 04:24:03 PDT
Comment on attachment 286180 [details] [diff] [review]
Patch to change from resource:/res to resource://gre/res. 

Thanks.
Comment 19 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-26 06:42:24 PDT
Comment on attachment 286180 [details] [diff] [review]
Patch to change from resource:/res to resource://gre/res. 

It would be nice if this could be approved for M9, this should be very safe, because it just fixes broken paths.
Comment 20 Mike Beltzner [:beltzner, not reading bugmail] 2007-10-26 12:14:27 PDT
Comment on attachment 286180 [details] [diff] [review]
Patch to change from resource:/res to resource://gre/res. 

a=drivers for after the M9 freeze
Comment 21 Georg Maaß 2007-10-28 07:09:14 PDT
In Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.9a9pre) Gecko/2007102804 Minefield/3.0a9pre the caret is not visible, when using MineField instead of XulRunner to launch a XulRunner application. So the problem is caused or at least influenced by something, which is shared by both.
Comment 22 Daniel Glazman (:glazou) 2007-10-28 12:48:49 PDT
(In reply to comment #17)
> (From update of attachment 286180 [details] [diff] [review])
> Probably better to ask Peter for review, I don't think Daniel is doing a lot of
> reviewing.

I am doing reviews. But apparently 3 days is too much :-)
Comment 23 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-28 12:51:53 PDT
(In reply to comment #22)
> I am doing reviews. But apparently 3 days is too much :-)


Ok, sorry, good to know.

Comment 24 Matt Crocker 2007-10-28 13:51:30 PDT
(In reply to comment #21)
> In Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de-DE; rv:1.9a9pre)
> Gecko/2007102804 Minefield/3.0a9pre the caret is not visible, when using
> MineField instead of XulRunner to launch a XulRunner application. So the
> problem is caused or at least influenced by something, which is shared by both.

Georg, did that build include the patch from this bug?
Comment 25 Mark Finkle (:mfinkle) (use needinfo?) 2007-10-29 17:43:45 PDT
*** Bug 401648 has been marked as a duplicate of this bug. ***
Comment 26 Mike Beltzner [:beltzner, not reading bugmail] 2007-10-31 11:47:25 PDT
Comment on attachment 286180 [details] [diff] [review]
Patch to change from resource:/res to resource://gre/res. 

a=endgame drivers for M9, should be safe
Comment 27 Reed Loden [:reed] (use needinfo?) 2007-10-31 11:52:08 PDT
Checking in content/html/document/src/nsHTMLDocument.cpp;
/cvsroot/mozilla/content/html/document/src/nsHTMLDocument.cpp,v  <--  nsHTMLDocument.cpp
new revision: 3.749; previous revision: 3.748
done
Checking in editor/composer/src/res/EditorOverride.css;
/cvsroot/mozilla/editor/composer/src/res/EditorOverride.css,v  <--  EditorOverride.css
new revision: 1.40; previous revision: 1.39
done
Checking in editor/libeditor/html/nsHTMLEditor.cpp;
/cvsroot/mozilla/editor/libeditor/html/nsHTMLEditor.cpp,v  <--  nsHTMLEditor.cpp
new revision: 1.562; previous revision: 1.561
done
Checking in editor/ui/composer/content/editor.js;
/cvsroot/mozilla/editor/ui/composer/content/editor.js,v  <--  editor.js
new revision: 1.249; previous revision: 1.248
done
Checking in layout/style/contenteditable.css;
/cvsroot/mozilla/layout/style/contenteditable.css,v  <--  contenteditable.css
new revision: 3.4; previous revision: 3.3
done
Comment 28 Georg Maaß 2007-11-02 02:57:11 PDT
In XULRUnner Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9a9pre) Gecko/2007110108 this really seems to be fixed. The caret is visible now.
Comment 29 Marcia Knous [:marcia - use ni] 2007-11-06 14:57:19 PST
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007110108 prism/0.8. I followed Mark's steps in the initial report to verify.
Comment 30 Mark Finkle (:mfinkle) (use needinfo?) 2008-02-02 16:11:44 PST
*** Bug 415380 has been marked as a duplicate of this bug. ***
Comment 31 Sebastian Deutsch 2008-03-14 10:36:03 PDT
It's still in download version but i will compile a snapshot version. 
Comment 32 Matthias Versen [:Matti] 2008-06-16 22:27:43 PDT
*** Bug 439501 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.