crash at start-up: "Assertion `mutex->__data.__owner == 0' failed." [@ _cairo_xlib_display_get]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: miko, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7) Gecko/2007080209 GranParadiso/3.0a7
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/thunderbird-3.0a1pre.en-US.linux-i686.tar.bz2

Nightly build of thunderbird crashes at start-up. It creates a window, but then immediately crashes.
 

Reproducible: Always

Steps to Reproduce:
1. ./thunderbird

Actual Results:  
It did create and show default window (for about 1 second), then crashed with a message:
thunderbird-bin: pthread_mutex_lock.c:82: __pthread_mutex_lock: Assertion `mutex->__data.__owner == 0' failed.
/home/miko/thunderbird/crashreporter: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory
(the libcurl is another problem I belive - I am using current curl with libcurl.so.4)

Expected Results:  
No crash

I am using archlinux distribution with latest packages:
 curl 7.16.4, cairo 1.4.10

Here is the output of thunderbird -g:
/usr/bin/gdb ./thunderbird-bin -x /tmp/mozargs.wb7450
GNU gdb 6.6
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) run
Starting program: /home/miko/thunderbird/thunderbird-bin 
[Thread debugging using libthread_db enabled]
[New Thread -1224767792 (LWP 7455)]
[New Thread -1232520304 (LWP 7458)]
[New Thread -1240966256 (LWP 7459)]
[New Thread -1252000880 (LWP 7460)]
[New Thread -1260393584 (LWP 7461)]
[New Thread -1268786288 (LWP 7462)]
[New Thread -1277777008 (LWP 7464)]
[Thread -1277777008 (LWP 7464) exited]
[New Thread -1277777008 (LWP 7465)]
[New Thread -1286419568 (LWP 7466)]
[New Thread -1294849136 (LWP 7467)]
[New Thread -1303241840 (LWP 7468)]
[New Thread -1311634544 (LWP 7469)]
[New Thread -1320641648 (LWP 7470)]
[Thread -1320641648 (LWP 7470) exited]
[New Thread -1329034352 (LWP 7472)]
[Thread -1329034352 (LWP 7472) exited]
thunderbird-bin: pthread_mutex_lock.c:82: __pthread_mutex_lock: Assertion `mutex->__data.__owner == 0' failed.

Program received signal SIGABRT, Aborted.
[Switching to Thread -1224767792 (LWP 7455)]
0xb7f35410 in __kernel_vsyscall ()
(gdb) bt
#0  0xb7f35410 in __kernel_vsyscall ()
#1  0xb717b6e5 in *__GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2  0xb717cfd1 in *__GI_abort () at abort.c:88
#3  0xb7174bbe in *__GI___assert_fail (
    assertion=0xb7efd87c "mutex->__data.__owner == 0", 
    file=0xb7efdfd4 "pthread_mutex_lock.c", line=82, 
    function=0xb7efd8ae "__pthread_mutex_lock") at assert.c:78
#4  0xb7ef54ce in __pthread_mutex_lock (mutex=0x8caab9c)
    at pthread_mutex_lock.c:82
#5  0xb71155a5 in _cairo_xlib_display_get () from /usr/lib/libcairo.so.2
#6  0xb7115f0f in _cairo_xlib_screen_info_get () from /usr/lib/libcairo.so.2
#7  0xb71148f8 in _cairo_xlib_surface_create_internal ()
   from /usr/lib/libcairo.so.2
#8  0xb797bea6 in gdk_x11_ref_cairo_surface ()
   from /usr/lib/libgdk-x11-2.0.so.0
#9  0xb7954b68 in _gdk_drawable_ref_cairo_surface ()
   from /usr/lib/libgdk-x11-2.0.so.0
#10 0xb7960850 in gdk_pixmap_ref_cairo_surface ()
   from /usr/lib/libgdk-x11-2.0.so.0
#11 0xb7954b68 in _gdk_drawable_ref_cairo_surface ()
   from /usr/lib/libgdk-x11-2.0.so.0
#12 0xb79533dd in gdk_cairo_create () from /usr/lib/libgdk-x11-2.0.so.0
#13 0xb6edc970 in ge_gdk_drawable_to_cairo ()
   from /usr/lib/gtk-2.0/2.10.0/engines/libthinice.so
#14 0xb6ed929f in thinice_style_draw_box ()
   from /usr/lib/gtk-2.0/2.10.0/engines/libthinice.so
#15 0xb7b7b410 in gtk_paint_box () from /usr/lib/libgtk-x11-2.0.so.0
#16 0xb7b412a3 in gtk_progress_bar_paint () from /usr/lib/libgtk-x11-2.0.so.0
#17 0xb7b3f1d9 in gtk_progress_create_pixmap ()
   from /usr/lib/libgtk-x11-2.0.so.0
#18 0xb7b3f4ef in gtk_progress_realize () from /usr/lib/libgtk-x11-2.0.so.0
#19 0xb78b305f in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#20 0xb78a4729 in g_type_class_meta_marshal ()
   from /usr/lib/libgobject-2.0.so.0
#21 0xb78a5e09 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#22 0xb78ba10b in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#23 0xb78bc0ff in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#24 0xb78bc449 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#25 0xb7c244fd in gtk_widget_realize () from /usr/lib/libgtk-x11-2.0.so.0
#26 0xb7c24afe in gtk_widget_set_parent () from /usr/lib/libgtk-x11-2.0.so.0
#27 0xb7abfedf in gtk_fixed_put () from /usr/lib/libgtk-x11-2.0.so.0
#28 0xb7abff58 in gtk_fixed_add () from /usr/lib/libgtk-x11-2.0.so.0
#29 0xb78b256a in g_cclosure_marshal_VOID__OBJECT ()
   from /usr/lib/libgobject-2.0.so.0
#30 0xb78a4729 in g_type_class_meta_marshal ()
   from /usr/lib/libgobject-2.0.so.0
#31 0xb78a5e09 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#32 0xb78ba10b in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#33 0xb78bc0ff in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#34 0xb78bc449 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#35 0xb7a771b6 in gtk_container_add () from /usr/lib/libgtk-x11-2.0.so.0
#36 0x08241974 in ?? ()
#37 0x08db0990 in ?? ()
looks like this is a gfx/thebes bug.

Bugzilla-jp has same report, but the reporter can reproduce hang and crash.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Updated

11 years ago
Component: General → GFX: Thebes
Keywords: crash
Product: Thunderbird → Core
QA Contact: general → thebes
Summary: crash at start-up: "Assertion `mutex->__data.__owner == 0' failed." → crash at start-up: "Assertion `mutex->__data.__owner == 0' failed." [@ _cairo_xlib_display_get]

Comment 2

11 years ago
Does this crash still occur in a recent trunk build?

(btw, the libcurl.so problem is bug 392919)
(Reporter)

Comment 3

11 years ago
No, the crash does not occur for me as of today on ArchLinux (using curl 7.17.1 btw). Look OK now. Thanks.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 4

11 years ago
WORKSFORME, since we don't know what fixed it exactly.
Resolution: FIXED → WORKSFORME
(Assignee)

Updated

8 years ago
Crash Signature: [@ _cairo_xlib_display_get]
You need to log in before you can comment on or make changes to this bug.