Closed Bug 392919 Opened 13 years ago Closed 12 years ago

Breakpad fails with error while loading shared libraries: libcurl.so.3

Categories

(Toolkit :: Crash Reporting, defect, P2, major)

x86
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla1.9beta2

People

(Reporter: aguertin+bugzilla, Assigned: ted)

References

()

Details

(Keywords: relnote)

Attachments

(1 file, 1 obsolete file)

2007-08-20-04 build (but it's not the minefield build that matters, it's my system that changed)

Breakpad fails to load on a crash. When run from the console it prints 
firefox/crashreporter: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory

Investigation shows I have no libcurl.so.3, just .4 (and .4.0.0). Creating .3 as a symlink to .4 makes breakpad work fine*.

This is Gentoo Linux, I have curl 7.16.4 (the default) installed. curl's been upgraded several times recently (I think?) so it may have actually been an earlier upgrade that changed the .so version.


* The window shows up and I have a log of it being sent; The server's busy processing a 4 day backlog so I can't actually verify it shows up yet.
I think this is you, not us.  Especially if you're on Gentoo.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
A quick google search shows that at least Fedora and Mandriva may also have this problem:
http://www.warsow.net/forum/viewtopic.php?id=15279

It looks like the change from .3 to .4 happened with curl 7.16
This actually looks valid at a second glance.  I don't know how to fix it, though.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
For reference: http://curl.haxx.se/changes.html
 Fixed in 7.16.0 - October 30 2006 
#  the SONAME on the shared library was bumped from 3 to 4
Since the functions we're using didn't actually change, we should be able to just look for both libs and load whatever we find dynamically.
Attached patch dynamically load libcurl (obsolete) — Splinter Review
This works with libcurl.so.4 when compiled against curl-7.15.5 and works with libcurl.so.3 when compiled against curl-7.16.2.
Assignee: nobody → ajschult
Status: REOPENED → ASSIGNED
Attachment #283129 - Flags: review?(ted.mielczarek)
Comment on attachment 283129 [details] [diff] [review]
dynamically load libcurl

I'm not comfortable taking a change this big locally.  If we need to do this, we should get it integrated upstream.
Attachment #283129 - Flags: review?(ted.mielczarek) → review-
confirmed with Firefox 3 Beta 1 RC 3 on Fedora 8, the crashreporter fail to catch the crash with /opt/firefox/crashreporter: error while loading shared libraries: libcurl.so.3: cannot open shared object file: No such file or directory 
Flags: blocking1.9?
Also confirmed on Mandriva Linux 2008.0 with Fx3b1.
Filed this upstream as http://code.google.com/p/google-breakpad/issues/detail?id=225 .  ajschult: do you think you could diff against Breakpad SVN and submit the patch there?  We'll still need to take that Makefile change here once we merge from upstream.
Oh, fwiw, we applied this patch to our XULRunner for our 0.3 release. So far no issues have been reported that I'm aware of.
Moving to blocking and setting P2 since we don't have crash reporting data on modern linux.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
adding relnote keyword for beta 1.
Keywords: relnote
Ok, I committed Andrew's patch in Breakpad issue 225, so we'll have to sync to Breakpad trunk again to pick it up.
Shouldn't this block beta2?  Isn't one of the big points of the beta getting feedback from things like crash reporter?
Update Breakpad to latest SVN and slight fixes to crashreporter code to accommodate.
Assignee: ajschult → ted.mielczarek
Attachment #283129 - Attachment is obsolete: true
Attachment #291309 - Flags: review?(mark)
Attachment #291309 - Flags: review?(mark) → review+
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M10
Version: unspecified → Trunk
i was not able to send a report with the current nightly. I got Crash report submission failed

and the console output :

(gecko:3086): Gtk-WARNING **: Unable to locate theme engine in
module_path: "nodoka",
Gtk-Message: Failed to load module "gnomebreakpad":
libgnomebreakpad.so: cannot open shared object file: No such file or
directory

(crashreporter:3106): Gtk-WARNING **: Unable to locate theme engine in
module_path: "nodoka",
Gtk-Message: Failed to load module "gnomebreakpad":
libgnomebreakpad.so: cannot open shared object file: No such file or
directory


and the breakpad log :
[Thu 06 Dec 2007 03:58:53 PM PST] Crash report submission failed:
[Thu 06 Dec 2007 03:59:49 PM PST] Crash report submission failed:
[Thu 06 Dec 2007 04:01:08 PM PST] Crash report submission failed:
(In reply to comment #18)
> i was not able to send a report with the current nightly. I got Crash report
> submission failed

Filed Bug 407229 for this issue
verified fixed with the current linux nightly trunk build. Breakpad is comming up on a crash. So changing this bug to verified.

However breakpad fails to send on Fedora, thats bug 407229
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.