Setting start page location to about: shows about: page but without thunderbird icon

VERIFIED FIXED in Thunderbird 3

Status

Thunderbird
General
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: abillings, Assigned: philor)

Tracking

Thunderbird 3

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
If the user sets the start page location to about: in Thunderbird 2.0.0.6, the page will show version information, etc. The top left of the box on the page has a linked labeled "thunderbird" that seems to be the alt text for a Thunderbird icon that should be there. There is a box around the text that is probably meant to be a border on the image.

This is seen in XP, Vista, and OS X (all that I've checked).
This sounds a little like bug 391305, which I saw yesterday... Not sure if it's a dupe or if there's another open bug to dupe to, but might keep it in mind regardless.

Updated

10 years ago
OS: Mac OS X → All
Hardware: PC → All
I "think" it's a dupe: what do you think, Al? I haven't got the privileges to change the status of this bug.

Updated

10 years ago
Duplicate of this bug: 391305

Comment 4

10 years ago
Shounds like some access right problem since about.xhtml uses <img src="about:logo" alt="&brandShortName;"/> and about:logo by it self is working.
(Reporter)

Comment 5

10 years ago
This doesn't seem to be a dupe, per se, though related. The other is really that about:logo shows the wrong logo. This is simply about the fact that about: doesn't show the logo when it should.
(In reply to comment #5)
> This doesn't seem to be a dupe, per se, though related. The other is really
> that about:logo shows the wrong logo. This is simply about the fact that about:
> doesn't show the logo when it should.
> 

Originally, when I reported bug 391305, I addressed both questions: about:logo displays the wrong logo and about: doesn't display any logo. I thought both problems were related, and that having "the" Tb logo display on both pages would be a lesser waste of human resources than working on both problems separately. I've been overruled, see bug 391305 comment #2 and bug 391305 comment #5. Somehow I "know" that if I reopen that bug, I'll get rapped over the knuckles. Maybe you should open a new bug, just about the tyrannosaurus in the Tb about:logo and nothing else?

Comment 7

10 years ago
(In reply to comment #6)
> the knuckles. Maybe you should open a new bug, just about the tyrannosaurus in
> the Tb about:logo and nothing else?

No need, as it's working on trunk (see bug 391305 comment #5), and it's hardly something that would end up in the 2.0 builds anyway. If it's not working for you on trunk, then open a bug about it.
(Bug still there:)

[Mozilla Thunderbird, version 3.0a1pre (2008041903)] (nightly) (W2Ksp4)

Works.

[Mozilla Thunderbird, version 2.0.0.15pre (20080410)] (nightly) (W2Ksp4)

Broken.
Yes, this bug is fixed on trunk (comment 7) and, I'm guessing, unlikely to get fixed on branch. I'd actually recommend WONTFIXing it for the branch.

Comment 10

10 years ago
Um, comment 7 was about a specific bug comment only, not this bug it self. 

Re comment #8, Serge, how can you tell that it works on trunk atm (I don't think so), considering bug 424767? 
(In reply to comment #10)
[...]
> Re comment #8, Serge, how can you tell that it works on trunk atm (I don't
> think so), considering bug 424767? 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041601 SeaMonkey/2.0a1pre

I can display the about: page as a Mail Start Page, provided that I call it chrome://global/content/about.xhtml and not just plain about:
(Assignee)

Comment 12

10 years ago
http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/mailnews/base/src/nsMsgContentPolicy.cpp&rev=1.52&mark=282-302#282 - SM uses a list of exposed protocols (since their real list is everything including what the browser exposes) which includes about; we use our actual exposed protocols, which don't include about.
(Assignee)

Comment 13

10 years ago
Unless I wind up having to do something other than what I want there, should end up fixed by bug 424767.
Assignee: nobody → philringnalda
Depends on: 424767
(Assignee)

Comment 14

10 years ago
Fixed on the trunk by bug 424767; really don't think we're going to want to take it on the branch.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Status: RESOLVED → VERIFIED
Target Milestone: --- → Thunderbird 3
You need to log in before you can comment on or make changes to this bug.