Closed Bug 391792 Opened 13 years ago Closed 13 years ago

Major Update from 1.5x to 2.x delete Update History

Categories

(Thunderbird :: General, defect, blocker)

x86
Windows XP
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 372981

People

(Reporter: cbook, Unassigned)

Details

Attachments

(3 files)

During the Major Update from Thunderbird 1.5.0.12 to 2.0.0.6 the Update History is deleted and show no update and also not the update from 1.5.0.12. This is fine on Mac and Linux, but fail on XP

The Update Status is install pending. I will attach my update log files.
Attached file active update.xml
the active-update.xml file
Attached file updates.xml file
Attached file updates.log
Severity: normal → blocker
Not really deleted, but not displayed ?
Severity: blocker → normal
Severity: normal → critical
There is a set of active-updates and updates xml files in the user profile. The information contained in those is what gets displayed in the software updates history after the major update to 2.0x.

I tried a major upate, then an update to a nightly 2007pre. After the major update, there was no software history, but after the nightly, there was an entry there.

1.5x and 2.0x might look for these files in different locations.

See bug 368082, a similar problem is describe there, for Firefox MU.
Severity: critical → blocker
Sounds exactly like bug 372981 to me.
Yeah, I think Phil's right, this is a dupe of Bug 372981.
per the comments Phil and I made on Friday, duping to 372981.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372981
You need to log in before you can comment on or make changes to this bug.