Upgrade to Flashblock 1.5.4.1

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: alqahira, Assigned: alqahira)

Tracking

({fixed1.8.1.8})

unspecified
PowerPC
Mac OS X
fixed1.8.1.8
Bug Flags:
camino1.5.2 +

Details

(Whiteboard: [camino-1.5.2])

Attachments

(1 attachment, 1 obsolete attachment)

Philip mentioned in our 1.5.1 testing thread that there's a new version of Flashblock out.

Unless there are other issues found with the 1.5.1 RC, this is too late for 1.5.1, but we should land it elsewhere and then take it for 1.5.2.

We probably also need to add "Check for Flashblock updates" to the Release Checklist.
Flags: camino1.5.2?

Comment 1

11 years ago
I strongly recommend bypassing 1.5.4 and go for 1.5.4.1 (aka 1.5.unstable) which is actually in http://downloads.mozdev.org/flashblock/flashblock-1.5.4.1.xpi although there is no link to this on our installation webpage (because I forgot! It's on AMO though). See <http://flashblock.mozdev.org/installation1.html> for the grotty reason why.

> We probably also need to add "Check for Flashblock updates" to the Release
> Checklist.

Can you put this in a script somewhere?

cvs -d :pserver:guest@mozdev.org:/cvs login
cvs -d :pserver:guest@mozdev.org:/cvs co flashblock/source/content/flashblock/flashblock.xml
(In reply to comment #1)
> Can you put this in a script somewhere?
> 
> cvs -d :pserver:guest@mozdev.org:/cvs login
> cvs -d :pserver:guest@mozdev.org:/cvs co
> flashblock/source/content/flashblock/flashblock.xml

We could put it in the makefile (and I think maybe we considered it in discussion around the original bug), but in general we want to make sure that our release builds are using only stable components (e.g., final Gecko tags).  We could put the Flashblock tag in the makefile, too, but then we're back to maintenance, and landing flashblock.xml ourselves is just about the same as fixing the Makefile ;)

Now that we've missed an update once, we'll be more likely to remember to check in the future, too.

Philip, are any of the changes between 1.5.3 and 1.5.4(.1) critical (security or breakages) such that we should go ahead and land the newer version right now?  If not, I'm personally inclined to wait and see what comes of the proposal in bug 384729 comment 15, at least until we get closer to Camino 1.5.2.

Comment 3

11 years ago
For 1.5.4.1:
[fixed] Stop DDoSing flash heavy websites.

For 1.5.4:
[fixed] 17197 Flash not being unblocked properly on Gran Paradiso.
[fixed] Crashes and frame/iframe regressions in OS2 thanks to Steve Wendt.
[fixed] Bug 16953 Broken object detection blocks liveconnect (javascript -> Java applet) and silverlight objects from initializing properly.

Since you don't care about Gecko 1.9a (Gran Paradiso) or OS2 or Silverlight you could stick to 1.5.3. But if you upgrade make sure you get the version that has the patch in 1.5.4.1 that stops sending unnecessary traffic to flash heavy websites.
Philip, do you guys have any plans to release something newer in the next couple of weeks, or should we go ahead and land 1.5.4.1 now for 1.5.2?

If not, I can go ahead and prepare a patch....
Assignee: nobody → alqahira
Summary: Upgrade to Flashblock 1.5.4 → Upgrade to Flashblock 1.5.4.1

Comment 5

11 years ago
No releases planned for the next couple of weeks, or next couple of months either. So go ahead and land 1.5.4.1.
Created attachment 282645 [details] [diff] [review]
upgrade to 1.5.4.1

Here's the upgrade patch; per comment 0, it also adds a note to the Release Checklist.
Attachment #282645 - Flags: superreview?(mark)

Comment 7

11 years ago
The flashblock1.5.4.1.xpi contains a flashblock.css that is slightly different than the one shipped with Camino: it includes a ruleblock for the SilverLight plugin.

> object[classid*="32C73088-76AE-40F7-AC40-81F62CB2C1DA"],
> object[type="application/ag-plugin"],
> object[source*=".xaml"],
> object[sourceelement*="xaml"],
> embed[type="application/ag-plugin"],
> embed[source*=".xaml"]
> {
>  -moz-binding: none !important;
> }
Shouldn't that be included with Camino as well ?

I noticed some issues with loading a SilverLight page the other day, using Camino Trunk and the FlashBlock plugin active (ending up with a blank page). Disabling Flashblock solved the issue.
Manually upgrading Flashblock to 1.5.4.1 (both the xml and the css file) in Camino allowed the page to load correctly with Flashblock on, sort of: double display of movie, but that is another issue, and is present in Minefield as well.
sample: http://www.microsoft.com/silverlight/
(You must accept the cookies)

Comment 8

11 years ago
> Shouldn't that be included with Camino as well ?

Yes. Somehow our broken object detection code interferes with javascript generated Silverlight objects and Java applets (this doesn't apply to static html markup). Probably some sort of timing issue. This rule block just stops flashblock from trying to probe silverlight objects. You should also include the Java rule block as well.
Created attachment 282708 [details] [diff] [review]
upgrade to 1.5.4.1 with css changes, too

Now with flashblock.css changes, too; thanks for catching that.
Attachment #282645 - Attachment is obsolete: true
Attachment #282708 - Flags: superreview?
Attachment #282645 - Flags: superreview?(mark)
Comment on attachment 282708 [details] [diff] [review]
upgrade to 1.5.4.1 with css changes, too

er, mento, this was meant for your queue last week, but the "non-matching request address get silently dropped" bug bit me :(
Attachment #282708 - Flags: superreview? → superreview?(mark)

Comment 11

11 years ago
Comment on attachment 282708 [details] [diff] [review]
upgrade to 1.5.4.1 with css changes, too

>+  http://flashblock.mozdev.org

Trailing slash

Do we really want this in the release checklist?  I don't think we'd ever land a Flashblock update immediately prior to a release.
Attachment #282708 - Flags: superreview?(mark) → superreview+

Updated

11 years ago
Flags: camino1.5.2? → camino1.5.2+
Checked in on trunk, MOZILLA_1_8_BRANCH, and CAMINO_1_5_BRANCH for Camino 1.5.2.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.8
Resolution: --- → FIXED
Whiteboard: [camino-1.5.2]
Er, without the changes to the release checklist, per discussion with mento on irc....
You need to log in before you can comment on or make changes to this bug.