Better minimum size for browser window

RESOLVED DUPLICATE of bug 897160

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 897160
12 years ago
6 years ago

People

(Reporter: samuel.sidler+old, Unassigned)

Tracking

({regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

In Firefox 2, we specified a minimum window size that actually had a little sliver of content showing in it. On trunk, the minimum window size is way smaller. Observe the attached screenshot.

STR:
 1. Drag the window dragger thing in the bottom right as far to the top left as you can.

(Firefox 2 on the left, Minefield 2007-08-12 on the right.)
Summary: Better minimum size for window → Better minimum size for browser window
The same problem here with version 3.0.6. I could get it even smaller but at restart it has the shown size. This is a major usability issue for simple users.

(Using Mandriva Cooker)
Can someone attach a screenshot of the minimum window size for Safari?
Shell integration doesn't do anything with the size of windows so moving over to core -> widgets
Component: Shell Integration → Widget
Product: Firefox → Core
QA Contact: shell.integration → general
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b99) Gecko/20090604 Firefox/3.5b99

Here is a screenshot comparing Safari Version 3.2.3 (4525.28.3) to Firefox 3.5b99 on Mac OSX 10.4 (Tiger).  It appears that Safari always shrinks to the last known size.  The attached screenshot reflects the default size (no manual resizing of window prior to stretching/shrinking).

I'll follow this up with a screenshot of the absolute minimum size of a Safari window.
Here's a screenshot showing the absolute minimum size of Safari vs Firefox.  Look how cute Firefox is.
So when it is a regression we need a regression window.
I'm not sure it's a regression on Windows, only Mac. For Mac, I haven't checked but... this regressed with the switch Cocoa widgets almost certainly.
(In reply to comment #8)
> I'm not sure it's a regression on Windows, only Mac. For Mac, I haven't checked
> but... this regressed with the switch Cocoa widgets almost certainly.

Yeah, that was the reason. Adding bug 326469 to the dependency list.
Blocks: cocoa
Hardware: PowerPC → All
Any progress on this ?
OS: Mac OS X → All
Duplicate of this bug: 236781
obsolete since bug 897160 was fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 897160
You need to log in before you can comment on or make changes to this bug.