Closed Bug 392305 Opened 15 years ago Closed 15 years ago

XMLList is not defined

Categories

(Core :: JavaScript Engine, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: bc, Assigned: igor)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Bug 386265 caused XMLList is not defined errors in the browser only. You can run other XMLList tests from <http://test.bclary.com/tests/mozilla.org/js/menu>
Flags: blocking1.9?
Assignee: general → igor
I'm not sure this is real anymore. I'm doing another build to check. ETA a few minutes.
Igor, I can reproduce this with cvs builds but not with nightlies. I have to go out for a couple of hours, and I'll look into it more when I get back. If you want to mark it WFM, that is ok.
Blocks: 392049
No longer blocks: 392049
Oddly enough, cx->runtime->atomState.lazy.XMLListAtom seems to be an atom for cmd_selectAll when I am able to reproduce this locally.
(In reply to comment #3)
> Oddly enough, cx->runtime->atomState.lazy.XMLListAtom seems to be an atom for
> cmd_selectAll when I am able to reproduce this locally.
> 

When I added the following code tp the bottom of StdNameToAtom in jsapi.c before the function return,

#if 1
    if (atom && stdn->name) {
        char buf[100];
        js_PutEscapedString(buf, sizeof(buf), ATOM_TO_STRING(atom), 0);
        if (strcmp(buf, stdn->name) != 0) 
            fprintf(stderr, "wanted=%s\ngot=%s\nhadAtom=%d\n", stdn->name, buf, hadAtom);
        JS_ASSERT(strcmp(buf, stdn->name) == 0);
    }
#endif

I got the assert triggered once right after the build, but only once.
Attached patch fix v1Splinter Review
As a leftover from one of early versions of the patch I removed ATOM_PINNED from StdNameToAtom.
Attachment #276815 - Flags: review?(brendan)
Attachment #276815 - Flags: approval1.9?
Attachment #276815 - Attachment is patch: true
Attachment #276815 - Attachment mime type: text/x-patch → text/plain
Comment on attachment 276815 [details] [diff] [review]
fix v1

Oops, I should have seen that.

This explains all the follow-on bugs.

/be
Attachment #276815 - Flags: review?(brendan)
Attachment #276815 - Flags: review+
Attachment #276815 - Flags: approval1.9?
Attachment #276815 - Flags: approval1.9+
I checked in the patch from comment 5 to the trunk:

Checking in jsapi.c;
/cvsroot/mozilla/js/src/jsapi.c,v  <--  jsapi.c
new revision: 3.349; previous revision: 3.348
done
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Flags: blocking1.9? → in-testsuite+
Duplicate of this bug: 391885
Duplicate of this bug: 392273
verified fixed 1.9.0 linux/mac*/windows.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.