Closed Bug 392536 Opened 14 years ago Closed 13 years ago

Search query parameters not dynamically updated/kicked off when file state changes.

Categories

(Toolkit :: Downloads API, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9beta4

People

(Reporter: stephend, Assigned: Mardak)

References

Details

(Whiteboard: [downloadManager-ui][fixed by bug 419403])

Build ID: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre)
Gecko/2007081604 Minefield/3.0a8pre

Summary: Search query parameters not dynamically updated/kicked off when file state changes.

Steps to Reproduce:

1. Download a large-enough file (or be on a slow-enough connection), so you've got time to do this.
2. Enter a small substring of the filename, like "mul" for "Mulholland_Drive.pdf" (for example) in the "Search ..." textfield.
3. Leave the "mul" substring in the textfield, and wait for the download to complete.  Note that it appears in the "Search Results" view.
4. When the download completes, check the "Search Results" view.

Actual Results:

Once "Mulholland_Drive.pdf" completes--and moves from "Active" to "Completed", it disappears from the "Search Results" view until you backspace or add additional text, such as "Mull"

Expected Results:

I'd expect that even though the file has since completed its download, it should remain in the "Search Results" view.
I'm not sure I want this to work as popping up something in the search results could be counter intuitive.
(In reply to comment #1)
> I'm not sure I want this to work as popping up something in the search results
> could be counter intuitive.

It doesn't appear to the user that way (I can see both cases, though), so whichever is less complicated/jarring.  The net effect is that the user actually watches their search results get removed because it happens to change its state to "Complete", which I think is also bad. 

Whiteboard: [downloadManager-ui]
There's another case, and that is:

1. Download something large
2. Search for it
3. Cancel it

At this point (3), it disappears from the UI; if you adjust the search query by deleting a letter, it reappears.
Duplicate of this bug: 400300
Duplicate of this bug: 408503
Depends on: 419403
Assignee: nobody → edilee
Flags: in-litmus?
OS: Mac OS X → All
Hardware: PC → All
Whiteboard: [downloadManager-ui] → [downloadManager-ui][fixed by bug 419403]
Target Milestone: --- → Firefox 3 beta4
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified FIXED using:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008022804 Minefield/3.0b4pre

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008022804 Minefield/3.0b4pre

-and-

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022806 Minefield/3.0b4pre

Litmus testcases coming a bit later...
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.