Closed Bug 392625 Opened 13 years ago Closed 13 years ago

Category names with non-word characters get saved incorrectly in prefs.js, thus breaking color coding

Categories

(Calendar :: Calendar Views, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 321010

People

(Reporter: jrossiter, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: 0.7pre (2007081705) with Thunderbird 2.0.0.7pre (20070816)

Category names that contain non-word characters followed by spaces get saved incorrectly in prefs.js.  This breaks color coding because the view can't locate the expected category name.

Reproducible: Always

Steps to Reproduce:
1. Create a category named "Holiday / Vacation" or "Work - Teleconference" with a color applied
2. Create an event using one of those categories
3. View in week/month/etc. view - the colors are broken
4. View prefs.js or about:config
Actual Results:  
Category is saved as "calendar.category.color.vacation_/ holiday"

Notice the fact that the space trailing the / was not converted to an underscore.  This occurs with many non-word characters.

Expected Results:  
Non-word characters such as slash, dash, etc. should not break category names in prefs.js
Seems related to Bug 355874 and maybe Bug 321010.
Does this still occur in recent nightlies since bug 412258 was fixed?
Patch just submitted for bug 321010 (part1: illegal chars) should address any other chars that cause the category style rule to fail.
Depends on: 321010
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 321010
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.