The default bug view has changed. See this FAQ.

valid xsd:dateTime values being marked invalid

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
10 years ago
9 months ago

People

(Reporter: aaronr, Assigned: Merle Sterling)

Tracking

({fixed1.8.1.12})

Trunk
x86
All
fixed1.8.1.12

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.30 KB, application/xhtml+xml
Details
1.01 KB, patch
Doron Rosenberg (IBM)
: review+
smaug
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
Created attachment 277568 [details]
testcase

If I bind a range or an input to a valid xsd:dateTime value, the controls get marked invalid.  I tried the testcase under Novell and formsPlayer and they both handle the testcase correctly.  I guess we screwed up something somewhere because this worked not too long ago.  Happens on both trunk and branch.
(Assignee)

Comment 1

9 years ago
Created attachment 291969 [details] [diff] [review]
patch

nsSchemaValidatorUtils::ParseSchemaTime does not check if the end of the buffer has been reached after parsing the second digit of the seconds.
(Assignee)

Updated

9 years ago
Attachment #291969 - Flags: review?(doronr)

Updated

9 years ago
Attachment #291969 - Flags: review?(doronr) → review+
(Assignee)

Updated

9 years ago
Attachment #291969 - Flags: review?(Olli.Pettay)
Attachment #291969 - Flags: review?(Olli.Pettay) → review+

Updated

9 years ago
Assignee: nobody → msterlin
(Reporter)

Updated

9 years ago
Blocks: 410239
(Reporter)

Comment 2

9 years ago
checked into trunk for msterlin
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch
(Reporter)

Comment 3

9 years ago
checked into 1.8 branch for msterlin
Keywords: fixed1.8.1.12
Whiteboard: xf-to-branch
(Reporter)

Updated

9 years ago
Duplicate of this bug: 362839
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.