Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 393057 - valid xsd:dateTime values being marked invalid
: valid xsd:dateTime values being marked invalid
: fixed1.8.1.12
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Merle Sterling
: 362839 (view as bug list)
Depends on:
Blocks: 410239
  Show dependency treegraph
Reported: 2007-08-21 10:38 PDT by aaronr
Modified: 2016-07-15 14:46 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---

testcase (1.30 KB, application/xhtml+xml)
2007-08-21 10:38 PDT, aaronr
no flags Details
patch (1.01 KB, patch)
2007-12-06 15:40 PST, Merle Sterling
doronr: review+
bugs: review+
Details | Diff | Splinter Review

Description aaronr 2007-08-21 10:38:27 PDT
Created attachment 277568 [details]

If I bind a range or an input to a valid xsd:dateTime value, the controls get marked invalid.  I tried the testcase under Novell and formsPlayer and they both handle the testcase correctly.  I guess we screwed up something somewhere because this worked not too long ago.  Happens on both trunk and branch.
Comment 1 Merle Sterling 2007-12-06 15:40:22 PST
Created attachment 291969 [details] [diff] [review]

nsSchemaValidatorUtils::ParseSchemaTime does not check if the end of the buffer has been reached after parsing the second digit of the seconds.
Comment 2 aaronr 2008-01-07 13:44:47 PST
checked into trunk for msterlin
Comment 3 aaronr 2008-01-08 19:12:12 PST
checked into 1.8 branch for msterlin
Comment 4 aaronr 2008-01-11 18:14:16 PST
*** Bug 362839 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.