Closed Bug 393104 Opened 17 years ago Closed 17 years ago

[Proto] Event dialog: Documents dialog uses hardcoded strings

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: milupo, Assigned: sipaq)

References

Details

(Keywords: l12y, Whiteboard: [l10n impact])

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; hsb-DE; rv:1.8.1.5) Gecko/20070716 SeaMonkey/1.1.3
Build Identifier: 2007082106

The small dialog for the documents button in the New Event dialog is hardcoded, it isn'localizable. The hardcode is in file sun-calendar-event-dialog in function editURL (lines 1619-1640)

Reproducible: Always

Steps to Reproduce:
1. Choose any calendar view
2. Do right click
3. Click on new event
4. Click on button Documents


Actual Results:  
Documents dialog is after localization in English

Expected Results:  
Documents dialog should be in the new locale language
The issue could be in Sunbird too, but I couldn't test it in Sunbird.
Confirmed. Hard coded strings: http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/calendar/prototypes/wcap/sun-calendar-event-dialog.js&rev=1.27&mark=1632-1633#1625

I think this should be changed together with Bug 360533 to avoid unnecessary changes.
Status: UNCONFIRMED → NEW
Component: Lightning Only → General
Ever confirmed: true
OS: Windows ME → All
QA Contact: lightning → general
Hardware: PC → All
Summary: Documents dialog in event window hardcoded → [Proto] Event dialog: Documents dialog uses hardcoded strings
I'll try to fix this.
Assignee: nobody → bugzilla
Keywords: l12y
Status: NEW → ASSIGNED
Depends on: 360533
Attached file Patch v1 (obsolete) β€”
This patch fixes the issue in this bug as well as bug 360533 (see bug 360533 comment 2)
Attachment #278099 - Flags: review?(philipp)
Target Milestone: --- → 0.7
Well, I think this is not good idea to change values of entities without changing their names. Localizers won't see any changes in tinderbox.
Attached patch Patch v2 β€” β€” Splinter Review
Same as v1, but with renamed entities as suggested by Vlado
Attachment #278099 - Attachment is obsolete: true
Attachment #278103 - Flags: review?(philipp)
Attachment #278099 - Flags: review?(philipp)
Comment on attachment 278103 [details] [diff] [review]
Patch v2

This patch misses the corresponding changes in the .xul file.
Comment on attachment 278103 [details] [diff] [review]
Patch v2

Please put the localization strings in locales/en-US/chrome/prototypes/sun-calendar-event-dialog.*  for now, since this belongs to the prototype dialog.

Also, locale strings should be camelCase, i.e make the first letter lowercase.

r+ with that fixed. Stefan, which part of the xul file needs to be changed?
Attachment #278103 - Flags: review?(philipp) → review+
(In reply to comment #9)
> Stefan, which part of the xul file needs to be changed?

The part in sun-calendar-event-dialog.xul that references the no longer existing entities event.menu.options.url.label and event.toolbar.document.label. This parts need to be changed to reference the new entities.
I'll fix the open issues on checkin
Patch v2 checked in on HEAD and MOZILLA_1_8_BRANCH with Philipp's and Stefan's review comments addressed.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Whiteboard: [l10n impact]
Blocks: 362927
I tested patch v2 and it works. I used lightning.xpi from 2007-8-24 6.56 PTZ, without patch. So I had to work the patch into yet and to change the sun-calendar-event-dialog.xul. But it works, both the dialog (now Add Link instead of Documents) is translated now and the Save dialog as well.
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.0; lt; rv:1.8.1.7pre) Gecko/20070825 Calendar/0.7pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: