Closed Bug 393338 Opened 12 years ago Closed 12 years ago

talos tinderbox needs to munge build start times to match code tested

Categories

(Release Engineering :: General, defect, critical)

Other
Other
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: bhearsum)

References

Details

Attachments

(2 files)

The talos tinderbox on http://tinderbox.mozilla.org/Firefox/ is reporting bogus build start times.  The build start times reported need to correspond to the code being tested; otherwise the way the information fits into the tinderbox page doesn't make sense -- the wrong checkins get blamed, etc.  (The performance testing tinderboxes, which also download hourly builds from ftp, already do this correctly.)
This is a major problem.  It makes it confusing to figure out who broke the build, and more likely that they've left before the necessary builds have cycled.
Severity: normal → critical
Duplicate of this bug: 396133
Here's the code in tinderbox that does this:

http://mxr.mozilla.org/seamonkey/source/tools/tinderbox/build-seamonkey-util.pl#981

specifically, http://mxr.mozilla.org/seamonkey/source/tools/tinderbox/build-seamonkey-util.pl#1829

it looks like it basically grabs that last start time of a build from tinderbox, which should correspond to the latest build that got downloaded.
Ben/Rob H/Rob C any chance we can get a quick fix for this.   There are some thoughts in bug 400107 on quick hacks.

I took a look at the links from Vlad's comment...using that method I should be able to get something working today/tomorrow.
Assignee: nobody → bhearsum
Status: NEW → ASSIGNED
This patch adds an option to the TinderboxMailNotifier that lets it use the date of the last change as the 'builddate'. When enabled, the start times will be munged the same way the old perf machines are.
Attachment #285310 - Flags: review?(rcampbell)
This patch enables the 'useChangeTime' option on TinderboxMailNotifier. It also removes the MozillaChangePusher step from every builder. If each Build is forced to run with only one Change, the start times will be really wacky.
Attachment #285312 - Flags: review?(rcampbell)
Comment on attachment 285310 [details] [diff] [review]
patch to let buildbot talos slaves munge start times

the builddate change looks reasonable, I think. Nice fixes on the columnName construction down below. Who let that in? ;)
Attachment #285310 - Flags: review?(rcampbell) → review+
Attachment #285312 - Flags: review?(rcampbell) → review+
Checking in buildbot/status/tinderbox.py;
/cvsroot/mozilla/tools/buildbot/buildbot/status/tinderbox.py,v  <--  tinderbox.py
new revision: 1.6; previous revision: 1.5
done
Checking in master.cfg;
/cvsroot/mozilla/tools/buildbot-configs/testing/talos/perfmaster/master.cfg,v  <--  master.cfg
new revision: 1.13; previous revision: 1.12
done
Checking in perfrunner.py;
/cvsroot/mozilla/tools/buildbot-configs/testing/talos/perfmaster/perfrunner.py,v  <--  perfrunner.py
new revision: 1.6; previous revision: 1.5
done
The Talos Buildbot master was just restarted to enable the date munging code. It looks to be working perfect.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Mass move of Core:Testing bugs to mozilla.org:Release Engineering:Talos. Filter on RelEngTalosMassMove to ignore.
Component: Testing → Release Engineering: Talos
Product: Core → mozilla.org
QA Contact: testing → release
Version: Trunk → other
Component: Release Engineering: Talos → Release Engineering
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.