[FIX]Another way to trigger "ASSERTION: expected the float to be a child of the outer CB" with float, block-in-inline

RESOLVED FIXED in mozilla1.9alpha8

Status

()

Core
Layout
P1
normal
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Jesse Ruderman, Assigned: bz)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
mozilla1.9alpha8
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 278706 [details]
testcase

Same pair of assertion as in bug 393671, different testcase.

###!!! ASSERTION: expected the float to be a child of the outer CB: 'outOfFlowFrame->GetParent() == aOuterState.mFloatedItems.containingBlock', file /Users/jruderman/trunk/mozilla/layout/base/nsCSSFrameConstructor.cpp, line 1602

###!!! ASSERTION: float wasn't in the outer state float list: 'Not Reached', file /Users/jruderman/trunk/mozilla/layout/base/nsCSSFrameConstructor.cpp, line 1607
Blocks: 390425
Created attachment 279049 [details] [diff] [review]
Fix

So the issue is that we insert the new frames into the trailing inline before calling MoveChildrenTo.  We never used to have a situation where MoveChildrenTo got a list of frames but wasn't supposed to move them all..  but that's exactly what we have now.  So pass in the place to stop as well.
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #279049 - Flags: superreview?(roc)
Attachment #279049 - Flags: review?(roc)
OS: Mac OS X → All
Priority: -- → P1
Hardware: PC → All
Summary: Another way to trigger "ASSERTION: expected the float to be a child of the outer CB" with float, block-in-inline → [FIX]Another way to trigger "ASSERTION: expected the float to be a child of the outer CB" with float, block-in-inline
Target Milestone: --- → mozilla1.9 M8
Attachment #279049 - Flags: superreview?(roc)
Attachment #279049 - Flags: superreview+
Attachment #279049 - Flags: review?(roc)
Attachment #279049 - Flags: review+
Attachment #279049 - Flags: approval1.9+
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.