Open Bug 394154 Opened 13 years ago Updated 3 years ago

Relative positioned table causes horizontal scrollbar

Categories

(Core :: Layout, defect, P3)

x86
All
defect

Tracking

()

REOPENED

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Attachments

(5 files)

Attached file testcase
This might be a dupe, but I couldn't find one.

See testcase, which current trunk build I get a horizontal scrollbar, which doesn't happen with branch builds.

This regressed when the reflow branch landed.
OS: Windows XP → All
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
I'm pretty sure this is the outer table frame contributing to the overflow area. It shouldn't, but the invariant that the overflow area contains the frame size makes this impossible to fix by modifying the overflow area of the outer table frame.

I'm not sure what we're going to do about outer table frames and captions for 1.9. David, do you have a plan?
David, your table fixes don't change the size of the outer table frame so this is still going to be a problem. I'm guessing we just don't fix this for 1.9?
BTW I don't see the bug in the original site.
Flags: wanted-next+
Flags: blocking1.9-
Flags: tracking1.9+
I believe this is the same bug and I can offer a test case with results.

I generated two test pages. One did not use a position:relative offset of a table and one did. I took screen shots of 4 examples.

1 - Firefox 3 with no offset
2 - Firefox 3 with offset
3 - Firefox 2 with offset
4 - Opera 9.51 with offset

They are attached as test_results.png

In #2 a horizontal scrollbar appears. For the 3 cases with Firefox I used the Webdeveloper add-on to "Outline Block Level Elements". It is clear for #2 that the offset "expands" the block by the amount of the offset.

I have attached the two HTML test files as No_Offset.html and Offset.html



Duplicate of this bug: 459522
Duplicate of this bug: 460103
Hi
I think You cant understand the problem what I want to say.

Please check 2 Images, So you can easily understand the Problem.

I attatch 2 Images Which is the output from same CSS+HTML code in Mozilla and IE. Please See the Diffrence.
Regargs
R.D. Sagar
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.