"Trust junk mail headers set by SpamAssasin + Move new junk messages to Junk Folder" works only for default account

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Catalin Catana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-07)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: version 2.0.0.6 (20070728)

I'm running multiple email accounts within thunderbird and each one has its inbox folder (NOT using the Global Inbox). Every account uses POP3 to receive email.

SPAM filtering is done very well by the mail server, therefore i don't need to use  the "adaptive junk mail controls".

The "Junk Settings" for each account is setup in the same way for all my accounts as described below:

OFF - Enable adaptive mail controls for this account
OFF - Do not mark mail as junk if the sender is in ...

ON  - Trust junk mail headers set by: SpamAssasin
ON  - Move new junk messages to: 

      ON  - "Junk" folder on: ...
      OFF - Other: ...

      OFF -  Automatically delete junk mail older than ..n.. days

I expected that every email received on any of my accounts that has been tagged as junk by spamassasin to be moved automatically in the junk folder of the account that received it, but that happens only for the first mail account which is also the "default" account.

The junk mail received by the other mail accounts (NOT the default account) have the junk icon (therefore i think that thunderbird detected SA headers - i'm not 100% sure of this) but they aren't automatically moved to their junk folder.

Reproducible: Always

Steps to Reproduce:
1. Add 2 or more POP3 accounts (don't use global inbox)
2. Set one as default account
3. Set the following "Junk settings" identically for every account:

OFF - Enable adaptive mail controls for this account
OFF - Do not mark mail as junk if the sender is in ...

ON  - Trust junk mail headers set by: SpamAssasin
ON  - Move new junk messages to: 

      ON  - "Junk" folder on: ...
      OFF - Other: ...

      OFF -  Automatically delete junk mail older than ..n.. days

4. Receive emails tagged as spam with SA headers
Actual Results:  
When the emails are retrieved:
- ONLY the default (or the first account, or just one account - on my sistem the first account happens to be the default one too) account moves the junk mails into it's JUNK folder. 
- The rest of the accounts have all the Junk in their INBOX.

Expected Results:  
When the emails are retrieved, every new email marked as spam (through headers) by SpamAssasin should be moved automatically to the JUNK folder corresponding to the account that received it 

This should work for every account, NOT just for the first one or for the default account.

I'm using the default theme installed automatically by Thunderbird update.

Comment 1

10 years ago
I would like to confirm this behaviour, I originally thought that this feature was not working at all, but after finding this bug report, I tested it against my main/original (first account added to thunderbird), and it actually worked, it does not however work on any of my other accounts that are added to thunderbird (or to be specific, not the two accounts I tested, since I have many accounts, and most/not all of them get email with spamassassin tagging).

I am also using POP accounts, no IMAP here.

Comment 2

10 years ago
I forgot to mention that I am using Thunderbird 2.0.0.6

Comment 3

10 years ago
xref bug 381589
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> xref bug 381589
> 

This reference is wrong. We aren't experiencing the same thing.
What i reported is that "Trust junk mail headers set by: SpamAssasin"
is working correctly just for the default account and not working at all
for any of my other accounts (i have multiple accounts within my thunderbird).

I think that the bug is very simple to be fixed. I guess that multiple accounts wasn't took into consideration as a possibility when this was wrote therefore the code just looks at the first account , does his job and doen't go through every email account (it's missing a foreach loop)
(Reporter)

Comment 5

10 years ago
I forgot to point out the conclusion.

It will be nice if this option will work for the other accounts in the same way that it's working for the first account (in my case the first account happens to be the default account).
(Reporter)

Comment 6

10 years ago
(In reply to comment #0)
The following quote from my first post is not correct.

> The junk mail received by the other mail accounts (NOT the default account)
> have the junk icon (therefore i think that thunderbird detected SA headers -
> i'm not 100% sure of this) but they aren't automatically moved to their junk
> folder.

The junk icon for the SA junk mails received by the other accounts is not showed at all. Therefore i can say that the "Trust junk mail headers set by SpamAssasin" option doesn't do anything for these accounts.

Comment 7

10 years ago
for the accounts where it is not working, does it work if you change the target folder to "other:"?

does version 2.0.0.12 candidate affect the problem ?
 ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-mozilla1.8/

lastly, did you run version 1.5 and did you see the same problem there?
Severity: normal → major
Reporter, does this still occur in the latest supported 2.0.0.x / trunk nightlies?

(Please also answer comment #7)
Whiteboard: closeme 2008-08-07
(Reporter)

Comment 9

10 years ago
(In reply to comment #7)
> for the accounts where it is not working, does it work if you change the target
> folder to "other:"?
> 
> does version 2.0.0.12 candidate affect the problem ?
>  ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-mozilla1.8/
> 
> lastly, did you run version 1.5 and did you see the same problem there?
> 

I'm not sure about other versions .. but it's fixed under version 2.0.0.16 (20080708). I just made some tests and now the option works on all accounts.

Response to #8

Well ... i wouldn't know ... i'm just testing with the last stable versions.
As i said above, it's the issue doesn't exist in version 2.0.0.16 (20080708)
which is the latest stable version in this moment.

Thanks to all.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
-> WFM. (WORKSFORME)

Fixed is used for bugs fixed with known patches.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.