Add Bookmark popup should say Add Bookmark instead of Done

RESOLVED DUPLICATE of bug 393509

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 393509
11 years ago
9 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Steps to reproduce:

- Go to a site and call the Add Bookmark popup
- Note that you have the choice between Delete and Done. Both options seem to say that I already bookmarked this site, even if I did not

I'd say, Add Bookmark is the clearest button text in this case but I also wonder why Delete is not grayed out if the site is not yet already bookmarked.

Comment 1

11 years ago
I would bet that it has in fact already been bookmarked.  Note the star changes color.
(Reporter)

Comment 2

11 years ago
OK, a search showed me that the bookmark is indeed somewhere, although I don't know where. I think it has a hidden or non-existing default folder. Also a browser restart doesn't reveal where it is. It must be a mess in my bookmarks in the meantime with all the sites I bookmarked unintentionally. :)
I'm afraid this is an invalid bug :(, caused by misunderstanding of the feature + the hidden folder.
 
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 3

11 years ago
Note, this is a 'valid' bug.

When a user (like the reporter) clicks on 'Bookmark this Link', the panel that is shown doesn't describe that the bookmark has been created (by that click).
The 'delete' logic is then strange. Normal behaviour is to provide a 'Cancel'  button to 'undo' or 'cancel' that bookmark operation of that click.

Using Delete/Done instead of the usual 'Cancel/Ok' to abort or confirm the 'Bookmark This Link' operation is new and strange to many people. Because the panel doesn't describe this people will be confused by this.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 4

11 years ago
Ria, the added bookmark when you click in the star does go someplace but you won't see it in any of your views unless you search for it.

I opened a bug the other day on this, bug 393944.

Updated

11 years ago
Status: REOPENED → ASSIGNED

Comment 5

11 years ago
Created attachment 281004 [details] [diff] [review]
Patch

Changes:
"Done" to "Add Bookmark"
"Delete" to "Cancel"

Also swaps the buttons location (bug 392976), even though that was another bug I figured since messing with same code might as well do it in this patch also.
Assignee: nobody → supernova_00
Attachment #281004 - Flags: review?(mano)
Comment on attachment 281004 [details] [diff] [review]
Patch

As mentioned above, the item is bookmarked before the panel is opened (you can see the instant-apply interaction in action by choosing Bookmarks Toolbar Folder as the container for the "new" bookmark).
Attachment #281004 - Flags: review?(mano) → review-

Comment 7

11 years ago
So should it be "Ok" then?
(Reporter)

Comment 8

11 years ago
Maybe there should be a message on the pop-up like:

You just added a bookmark to your bookmarks collection.
 
-----   ---------------------
OK   | |  Delete new bookmark |
-----   ---------------------
These issues have already been debated in other bugs and on dev.apps.firefox.  I would have commented here earlier but I didn't know about this bug.

Here are the planned change for i8 of the new bookmark dialog UI (bug #393509):

Panel is instant apply:
-Add "Page Bookmarked" at the top of the panel
-remove done/ok/cancel, add small close button in the top left corner (right on
mac)
-There is still a remove bookmark button
-Clicking anywhere outside of the panel dismisses it
sorry, switch right/left for windows/mac

Comment 11

11 years ago
Alex, so can we just mark this a dupe of bug 393509 since it seems that the dialog is going to be redone in that bug anyways?

Assignee: supernova_00 → nobody
Status: ASSIGNED → NEW
Yeah this could be marked as a duplicate if it also reveals where the All Bookmarks folder is so I can delete all those unintended bookmarks :). In fact it was just a misunderstanding, so INVALID is also fine with me. 
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393509
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.