Event/Task dialog: Add Link: file:// protocol is not supported

VERIFIED DUPLICATE of bug 168680

Status

--
enhancement
VERIFIED DUPLICATE of bug 168680
12 years ago
11 years ago

People

(Reporter: koen.hendrickx, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
When you want a add a file to a task/event, 
You can add an url, but the file:// protocol is not supported.Only http and https are supported for the moment.

I think in earlier versions (v0.2) it was possible...
FYI: Protocol support was limited with Bug 368858 on purpose.
In Trunk builds we might consider using Toolkit method openURL() (see Bug 384139) instead.
Duplicate of this bug: 412417
Hardware: PC → All
Summary: Visit URL: file:// protocol is not supported → Event/Task dialog: Add Link: file:// protocol is not supported
Version: Trunk → unspecified
Lightning nightly build 6 feb 2008 seems to have rectified the problem - a file location can now be added as a link. Unfortunately, when the link is clicked, the location does NOT open.....should this be reported as a new bug, or as a continuation of this one?
Web URLs open OK in the browser...
Gordon, this is exactly the issue this bug is about.
(In reply to comment #5)
> Gordon, this is exactly the issue this bug is about.
> 

Ah. The original bug I filed was that you couldn't add a file reference in the Link function AT ALL.....
Duplicate of this bug: 447727

Updated

11 years ago
Flags: wanted-calendar1.0?

Comment 8

11 years ago
Hi. I doubt this is the right place for doing this but:
- What about putting a "Browse..." box inside the "Attach" box ?
This would just achieve complete functionnality, wouldn't it ?
Unfortunately, its more than just adding UI for adding a file. See bug 168680
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 168680
Status: RESOLVED → VERIFIED
Flags: wanted-calendar1.0?

Comment 10

11 years ago
(In reply to comment #9)
Couldn't this bug be left open for adding links to the files and let bug 168680 focus on attaching them ?
I think this bug has way higher chances of getting into 1.0 than bug 168680 and even if enhancement of link support is desired.
Scenario:
I want to add link to the file located on a network share and not attach it as it is being updated constantly.
You need to log in before you can comment on or make changes to this bug.