Don't close bookmarks menu when cut/copy/paste are selected from context menu

VERIFIED FIXED

Status

()

Firefox
Menus
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: Bryan, Assigned: Neil Deakin (not available until Aug 9))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007083015 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007083015 Minefield/3.0a8pre

Behavior is inconsistent:

1) Cut/Copy/Paste in the menu and it isn't sticky but using Delete it is
2) The drag of an item to another menu should cause the destination menu to open and remain sticky
3) Attempting to D&D an item between menus and the indication of where it's going to "land" when you release the mouse is one item below where you actually have your mouse pointer!  


Reproducible: Always

Steps to Reproduce:
1) Launch Minefield 
2) Cut/Copy/Paste in the menu and it isn't sticky but using Delete it is
3) Drag an item to another menu and observe that the destination menu doesn't open and certainly doesn't remain sticky
Actual Results:  
1) Launch Minefield 
2) Cut/Copy/Paste in the menu and it isn't sticky but using Delete it is
3) Drag an item to another menu and observe that the destination menu doesn't open and certainly doesn't remain sticky

Expected Results:  
1) That the use of the following functions Cut/Copy/Paste in the Bookmark menu doesn't cause the bookmark menu to lose it's stickiness and behaves just like using Delete does
2) That dragging an item to another menu would open the target menu and that target menu would remain sticky until dismissed by the user

Comment 1

10 years ago
Lets not have full URLs in bug summaries.. mmmk?
Depends on: 195031
Summary: The fix for https://bugzilla.mozilla.org/show_bug.cgi?id=195031 is very inconsistent in it's implementation → The fix for Bug 195031 is very inconsistent in it's implementation

Comment 2

10 years ago
I spun off the wrong placement of bookmarks into Bug 394401.

Comment 3

10 years ago
2) Probably is bug 337761.

Also, after dnd of a bookmark item the menu still closes itself, which I hoped bug 195031 would fix..
Please only one issue per bug.

This bug here is now about not closing the menu after cut/copy/paste.

Bug 195031 was about not closing menu after certain commands from the context menu were selected. Not closing menus while dragging is not that bug either.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: The fix for Bug 195031 is very inconsistent in it's implementation → Don't close bookmarks menu when cut/copy/paste are selected from context menu
Created attachment 279757 [details] [diff] [review]
add closemenu for cut/copy/paste
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Attachment #279757 - Flags: review?(mano)
Comment on attachment 279757 [details] [diff] [review]
add closemenu for cut/copy/paste

r=mano
Attachment #279757 - Flags: review?(mano) → review+
(Assignee)

Updated

10 years ago
Attachment #279757 - Flags: approval1.9?
since this is a browser/ only patch, you shouldn't need approval until after the freeze... so, you have one hour and twenty minutes to check this in ;)

Updated

10 years ago
Attachment #279757 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
I this checkin caused: https://bugzilla.mozilla.org/show_bug.cgi?id=395467
(In reply to comment #8)
> I this checkin caused: https://bugzilla.mozilla.org/show_bug.cgi?id=395467

False alarm, that bug was caused by another patch.
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007091005 Minefield/3.0a8pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.