Add "common app data directory" to nsDirectoryService

RESOLVED WONTFIX

Status

()

Core
XPCOM
RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: Wladimir Palant, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

7.78 KB, patch
Benjamin Smedberg
: review-
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
Created attachment 279467 [details] [diff] [review]
Patch

Currently we can get "\Document and Settings\<username>\Application Data" or "\Document and Settings\<username>\Local Settings\Application Data", there is no way to get to "\Document and Settings\AllUsers\Application Data". The patch adds this directory to nsDirectoryService as CmAppData.
Attachment #279467 - Flags: review?(benjamin)

Comment 1

11 years ago
What do you want to do with this directory? I can understand, perhaps, \Documents and Settings\All Users\Desktop or quicklaunch or start menu, but the Application Data subdirectory?
(Reporter)

Comment 2

11 years ago
It is for TomTom HOME - some files that are downloaded from the Internet should be accessible to all users. The default install location is application's install directory, but since this one isn't always writable we need a fallback location.

Comment 3

11 years ago
Comment on attachment 279467 [details] [diff] [review]
Patch

All Users is also not always writable: it's typically writable only by administrators. I don't think I want to take this patch: you can pretty easily include an XPCOM component in your app to do the same thing.
Attachment #279467 - Flags: review?(benjamin) → review-

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX

Comment 4

11 years ago
Personally, I think that any such "symbolic" directory should be resolvable in XULRunner - otherwise, it's almost impossible to get there from JS code, in case you need it for whatever reason.
For TomTom HOME, we'll probably just use the profile for now.

Updated

11 years ago
Duplicate of this bug: 391236
You need to log in before you can comment on or make changes to this bug.