If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add a About plugin dialog to right click menu in EM

VERIFIED FIXED in mozilla1.9.3a5

Status

()

Toolkit
Add-ons Manager
--
enhancement
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: tchung, Unassigned)

Tracking

unspecified
mozilla1.9.3a5
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; es-ES; rv:1.9a8pre) Gecko/2007090404 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; es-ES; rv:1.9a8pre) Gecko/2007090404 Minefield/3.0a8pre

It'd be great to add an "About Plugin" menu to the plugin on the Addons Manager.  This would be consistent with how Themes and Extensions does it. 



Reproducible: Always

Steps to Reproduce:
1. Install latest trunk
2. Tools > Addons
3. Right-Click a plugin in plugins tab
4. Verify there is no "About plugin" option
5. This exists for Themes and Extensions.   Can we consistently get it for plugins also?
Actual Results:  
Right-click plugin, no "About plugin" menu option

Expected Results:  
Right-click plugin, a "About plugin" menu option
I don't believe there is anything more available about the plugin than that listed in about:plugins. I guess we could list the mimetypes it supports though?
At least to some degree for the EM to do this Core -> Plugins would have to provide the metadata. There is some today but not much and often it isn't well formed. One bug to add one piece of metadata in a well formed manner (we currently strip out the href from anchors when present in the plugin description) is Bug 391972.

It is extremely doubtful that this would make Firefox 3.0 especially since the data desired from the plugin hasn't been defined much less implemented by Core -> Plugins. This will most likely need evangelism work to get the plugin vendors to add the metadata for the about dialog.

On the other hand we could add some but the value of doing so is questionable plus it wouldn't be the about dialog the user sees for add-ons.
Depends on: 391972
Target Milestone: --- → Future
(Reporter)

Comment 3

10 years ago
If you look at the other about menus for extensions and themes, the metadata can list out the name, version, description, created by, contributors, and Close button. If a home page is present, it has a link to it also.   Having this feature would make the feature more uniform across EM.   
(In reply to comment #3)
> If you look at the other about menus for extensions and themes, the metadata
> can list out the name, version, description, created by, contributors, and
> Close button. If a home page is present, it has a link to it also.   Having
> this feature would make the feature more uniform across EM.   
Right, and the name and description is already displayed in the main ui, plugins don't have equivalent metadata for contributors, iirc plugins don't have a created by equivalent, version is sometimes provided as part of the name or the description which makes it for the most part impossible to parse, and the close button is a non issue.

I agree it would be a good thing but we will either need to use different metadata to justify displaying an about plugin dialog since the metadata that is the same is already displayed in the main ui or Core -> Plugins would have to add the capability for plugin vendors to provide this metadata if we wanted it to be similar.
note: this was one of my concerns when adding non EM managed items to the Add-ons Mgr. People will expect that this sort of information is available because it is available for add-ons in the other views. If we add search engines, dictionaries, offline apps, microsummaries, etc. this same issue will occur... sometimes to a greater degree evem where we won't necessarily be able to display equivalent information in the main ui due to the non EM managed item not having the metadata equivalent information displayed in the main ui for EM managed add-ons.

Updated

10 years ago
Severity: normal → enhancement
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
Blocks: 392266
Target Milestone: Future → ---
The rewrite gave us this in I guess bug 554007
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
I would tend to say yes. :)
Status: RESOLVED → VERIFIED
Depends on: 554007
Target Milestone: --- → mozilla1.9.3a5
You need to log in before you can comment on or make changes to this bug.