Closed Bug 395606 Opened 13 years ago Closed 13 years ago

Address entry enhancement

Categories

(Thunderbird :: Message Compose Window, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 392932

People

(Reporter: berwyn, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: 2.0.0.6 (20070728)

Note: there is a bounty for this enhancement/plugin over at:
    http://micropledge.com/projects/thunderbird-addressing-plugin

Entering “To:” addresses when composing a new mail in Thunderbird is a bit icky. It forces one address per line, meaning the To: lines take too much screen real estate when you’ve got multiple addresses. It needs to:

* Work like Gmail or (dare I say it) MS Outlook.
* Not look like it limits addresses to one-per-line.
* Have TO: addresses on one line, CC: on another line, etc.

This isn’t a big job, but it’d improve the usability of Thunderbird in its primary task. Just that little bit extra to makes you feel warm and fuzzy inside. 

More specifically, here’s what the plugin needs to do.

* Comma- and semicolon-separated addresses do work, but badly. Text must not goe error-red and pressing Enter must not auto-move them to separate lines.

* Thunderbird address completion works great, but it only works for the first address on a line, not after a comma.

* When you press tab to complete an address, it completes the address but places you into the subject bar. It should leave you on the same line after a comma waiting for a new address. It should only go to the subject line if you press it again after the comma.

* Pressing Enter should take you to the next address bar which should be the CC: bar, not another TO: bar - because all TO: addresses will normally be on one line.

* In the TO: address box shift-tab moves you back to the TO: drop-down (and your cursor awkwardly disappears), but you expect it to move to the previous address line. Same for tab.


Reproducible: Always

Steps to Reproduce:
1. Compose a new mail
2. Enter the first email address and press comma space and enter another address
3. Text goes error-red until you've typed it all in.
4. address-completion doesn't work
5. Press Enter and thunderbird separates addresses into multiple lines.
Note: the pledge project for this at
    http://micropledge.com/projects/thunderbird-addressing-plugin
requires somebody to quote it in order for a pledge target to be set.
I think this is basically bug 392932. (We like to keep it one issue per bug report.)
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392932
Thank you for linking this to bug 392932.  However, I think 392932 is a subset of this bug and misses the following points. Is it possible to make 392932 a duplicate of this one instead of the other way around?  Cheers.

* When you press tab to complete an address, it completes the address but
places you into the subject bar. It should leave you on the same line after a
comma waiting for a new address. It should only go to the subject line if you
press it again after the comma.

* Pressing Enter should take you to the next address bar which should be the
CC: bar, not another TO: bar - because all TO: addresses will normally be on
one line.

* In the TO: address box shift-tab moves you back to the TO: drop-down (and
your cursor awkwardly disappears), but you expect it to move to the previous
address line. Same for tab.
(In reply to comment #3)
> Thank you for linking this to bug 392932.  However, I think 392932 is a subset
> of this bug and misses the following points. Is it possible to make 392932 a
> duplicate of this one instead of the other way around?  Cheers.

We tend to prefer smaller pieces. I think it's mostly implementation details... but e.g. point 2 I don't necessarily agree with.
Very good, thank you.

Regarding point 2, the point is that there needs to be some easier way to enter addresses into the CC box without selecting from a drop-down.  Gmail does this by letting you click on "Add Cc" or "Add Bcc".  Other clients also do similar things, and it is a good idea.

My proposal for point 2 above is one option because once we have multi-line addresses working fine, you no longer need the Enter key to jump to additional To: boxes.  There may be other intuitive keys to do the same thing, and discussion would be worth while.
there is additional discussion here:
http://forums.mozillazine.org/viewtopic.php?t=613392
The bounty for this is building up at http://micropledge.com/projects/thunderbird-addressing-plugin.

Would someone who might likely fix this like to sign-up to receive the bounty?
Comment 0 sounds like a good plan to me.

Most of this needs to happen in
Bug 440377 - Redesign recipients address fields (To, Cc, Bcc) as single-line input fields for multiple comma separated addresses - not one line/row per address

The rest, both for current multi-line and future single-line layout per bug 440377, is indeed a duplicate of 
Bug 392932 - Should also autocomplete when typing another comma-separated recipient on the same address line (multiple addresses)
Depends on: 440377
No longer depends on: 440377
You need to log in before you can comment on or make changes to this bug.