Closed Bug 395928 Opened 17 years ago Closed 16 years ago

Event Dialog: Unify wording by renaming Importance to Priority

Categories

(Calendar :: General, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: gkw)

References

Details

Attachments

(2 files, 3 obsolete files)

Currently the Event/Task dialog uses the wording 
    "Importance: None / Low / Normal / High"
in the Options menu and status bar.

Thunderbird uses the wording 
    "Priority: Low / Normal / High"
in the Options menu of the Message Compose window.

In the Task list context menu we use the wording
    "Priority: Not specified / Low / Medium / High"

The corresponding RFC2445 property is "PRIORITY". In the corresponding description the avaialable values are mapped to "HIGH", "MEDIUM" and "LOW".

To unify the wording I suggest to:

- reword "Importance" to "Priority"
- reword "None" to "Not specified"
- reword "Medium" to "Normal"

Christian, what do you think?
This is absolutely ok for me.
I'll provide a patch after the 0.7 release.
Assignee: nobody → ssitter
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: ssitter → nobody
Component: General → Theme
Product: Calendar → Firefox
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk
Oops, sorry, my bad, returning to the right component, awfully sorry about stomping your target milestone, please send hatemail to this address :(
Component: Theme → General
Product: Firefox → Calendar
Target Milestone: Firefox 3 → ---
Version: Trunk → Sunbird 0.7
Flags: wanted-calendar0.8?
We've already passed string freeze; setting wanted-0.8-
Flags: wanted-calendar0.8? → wanted-calendar0.8-
I'd like to take this, first version patch coming right up.
Status: NEW → ASSIGNED
Target Milestone: --- → 0.9
Attached patch patch v1 (obsolete) β€” β€” Splinter Review
first attempt to patch this.

(shouldn't be checked in until after 0.8 is released though)
Attachment #303083 - Flags: ui-review?(christian.jansen)
Assignee: nobody → nth10sd
Status: ASSIGNED → NEW
Whiteboard: [checkin-needed after 0.8]
Status: NEW → ASSIGNED
Comment on attachment 303083 [details] [diff] [review]
patch v1

First of all, this doesn't need an ui-review, as Christian already ok'ed this in comment 2.

But the patch still needs some work

>Index: calendar/calendar-event-dialog.dtd
>===================================================================
> <!ENTITY priority.level.none                "Not specified">
> <!ENTITY priority.level.none.accesskey      "N">
> <!ENTITY priority.level.low                 "Low">
> <!ENTITY priority.level.low.accesskey       "L">
>-<!ENTITY priority.level.medium              "Medium">
>-<!ENTITY priority.level.medium.accesskey    "M">
>+<!ENTITY priority.level.medium              "Normal">
>+<!ENTITY priority.level.medium.accesskey    "m">
> <!ENTITY priority.level.high                "High">
> <!ENTITY priority.level.high.accesskey      "H">

Please change the entity names, if you change the meaning of the string. Otherwise localizers might not pick this up. I suggest to use priority.level.normal and priority.level.normal.accesskey

While you're at it, please change the accesskey for priority.level.none.accesskey to "s" and give the "N" accesskey to priority.level.normal.accesskey, because that is the more common operation.

>Index: calendar/calendar.dtd
>===================================================================
>-<!ENTITY calendar.task.details.priority.label        "Importance:">
>+<!ENTITY calendar.task.details.priority.label        "Priority:">

Well, this sucks. The string is adequately named, but needs to be renamed for localizers. Please rename the entity. I suggest to use calendar.task.details.priority2.label

>Index: prototypes/sun-calendar-event-dialog.dtd
>===================================================================
>-<!ENTITY  event.menu.options.priority.label               "Importance">
>-<!ENTITY  event.menu.options.priority.accesskey           "m">
>-<!ENTITY  event.menu.options.priority.none.label          "None">
>+<!ENTITY  event.menu.options.priority.label               "Priority">
>+<!ENTITY  event.menu.options.priority.accesskey           "y">
>+<!ENTITY  event.menu.options.priority.none.label          "Not specified">

Same as above. I suggest that you use
- event.menu.options.priority2.label
- event.menu-options.priority2.accesskey
- event.menu.options.priority.notspecified.label

review- for now.
Attachment #303083 - Flags: ui-review?(christian.jansen) → review-
Attached patch patch v2 (obsolete) β€” β€” Splinter Review
patch v2 incorporating changes as well as files containing changed entities.
Attachment #303083 - Attachment is obsolete: true
Attachment #303300 - Flags: review?(bugzilla)
Flags: wanted-calendar0.8-
No checkin-needed until patch is reviewed.
Whiteboard: [checkin-needed after 0.8]
Comment on attachment 303300 [details] [diff] [review]
patch v2

>Index: locales/en-US/chrome/prototypes/sun-calendar-event-dialog.dtd
>===================================================================
>@@ -89,20 +89,20 @@
> <!ENTITY  event.menu.options.timezone.label               "Timezone">
> <!ENTITY  event.menu.options.timezone.accesskey           "z">
>-<!ENTITY  event.menu.options.priority.label               "Importance">
>-<!ENTITY  event.menu.options.priority.accesskey           "m">
>-<!ENTITY  event.menu.options.priority.none.label          "None">
>-<!ENTITY  event.menu.options.priority.none.accesskey      "o">
>+<!ENTITY  event.menu.options.priority2.label              "Priority">
>+<!ENTITY  event.menu.options.priority2.accesskey          "y">
>+<!ENTITY  event.menu.options.priority.notspecified.label  "Not specified">
>+<!ENTITY  event.menu.options.priority.notspecified.accesskey "o">
> <!ENTITY  event.menu.options.priority.low.label           "Low">
> <!ENTITY  event.menu.options.priority.low.accesskey       "L">

Could you please align the values of "event.menu.options.priority.notspecified.label" and "event.menu.options.priority.notspecified.accesskey" and provide an updated patch, since I'm pretty sure it has already bitrotted some.

Otherwise the patch looks fine. r=sipaq
Attachment #303300 - Flags: review?(bugzilla) → review+
Version: Sunbird 0.7 → unspecified
Attached patch patch v3 β€” β€” Splinter Review
Patch applies cleanly against latest cvs trunk, never bitrotted.

Incorporated comments, now everything is aligned properly, bringing over review.
Attachment #303300 - Attachment is obsolete: true
Attachment #316521 - Flags: review+
Whiteboard: [checkin-needed]
Keywords: checkin-needed
Whiteboard: [checkin-needed]
Checked in on HEAD and MOZILLA_1_8_BRANCH.
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Summary: [Proto] Event Dialog: Unify wording by renaming Importance to Priority → Event Dialog: Unify wording by renaming Importance to Priority
(In reply to comment #12)
> Incorporated comments, now everything is aligned properly, bringing over
> review.

Gary, this is basically my failure to take another look at your updated patch. 

I only asked you to only align the "event.menu.options.priority.notspecified.label" and "event.menu.options.priority.notspecified.accesskey" entities, not half of the file. This messes up cvs blame a lot.
(In reply to comment #14)
> Gary, this is basically my failure to take another look at your updated patch. 
> 
> I only asked you to only align the
> "event.menu.options.priority.notspecified.label" and
> "event.menu.options.priority.notspecified.accesskey" entities, not half of the
> file. This messes up cvs blame a lot.
> 

Simon, apologies for my incompetence and misreading of your instructions, I'll keep that in mind in the future.
I checked this issue in the latest nightly build and this patch is a little bit incomplete.

STR:

- open the edit event dialog
- go to the options dialog and chose an 'priority' entry (e.g. Low)
- check the status bar of the edit dialog -> 'Importance' is displayed, but this should be also 'Priority'

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
You're right, Andreas. We seem to have missed 

http://mxr.mozilla.org/mozilla1.8/source/calendar/locales/en-US/chrome/prototypes/sun-calendar-event-dialog.dtd#182

Gary, could you whip up a patch for that as well?
Attached patch fix for missing stuff (obsolete) β€” β€” Splinter Review
Sure, here's the patch for the missing stuff.
Attachment #317328 - Flags: review?(bugzilla)
Comment on attachment 317328 [details] [diff] [review]
fix for missing stuff

Gary, this patch misses the corresponding changes to mozilla/calendar/prototypes/wcap/sun-calendar-event-dialog.xul 

Therefore, I have to give this patch a review-
Attachment #317328 - Flags: review?(bugzilla) → review-
Attached patch missing fix v2 β€” β€” Splinter Review
Arrgh, how could I have missed that?

Anyway, here's the latest one with the .xul file patched up.
Attachment #317328 - Attachment is obsolete: true
Attachment #317401 - Flags: review?(bugzilla)
Comment on attachment 317401 [details] [diff] [review]
missing fix v2

r=sipaq
Attachment #317401 - Flags: review?(bugzilla) → review+
Followup patch checked in on HEAD and MOZILLA_1_8_BRANCH. Thanks Gary!
Status: REOPENED → RESOLVED
Closed: 17 years ago16 years ago
Resolution: --- → FIXED
Checked in lightning 2008042421 and Sunbird 20080424 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: