Last Comment Bug 395972 - Crash in [@ nsPluginInstanceOwner::FixUpPluginWindow(int)]
: Crash in [@ nsPluginInstanceOwner::FixUpPluginWindow(int)]
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://www.pepsiproductfacts.com/inde...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-12 15:28 PDT by Marcia Knous [:marcia - use ni]
Modified: 2012-02-22 16:22 PST (History)
6 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Marcia Knous [:marcia - use ni] 2007-09-12 15:28:50 PDT
Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8) Gecko/2007091211 GranParadiso/3.0a8.

STR:
1. Open a bunch of tabs, including the one in the URL field. I also had meebo.com and http://www.oneify.com/ open in this session.
2. I crash.

Crash report is here: http://crash-stats.mozilla.com/report/index/971a3a85-617b-11dc-a086-001a4bd43ef6?date=2007-09-12-22

I crashed in this stack before when I was trying to reproduce Bug 395814.
Comment 1 Marcia Knous [:marcia - use ni] 2007-09-14 19:00:44 PDT
I forgot to add that I was testing with the r60 version of flash when I crashed.
Comment 2 Stephen Donner [:stephend] 2007-09-20 01:46:07 PDT
Setting severity to "critical" from "normal", because--even though this appears with a beta plugin--crashers have always traditionally been marked as such.
Comment 3 Wayne Mery (:wsmwk, NI for questions) 2010-01-02 14:14:45 PST
bp-00f997c3-82e7-4849-8360-51b542091227 FF 3.5.6 has an email address
Comment 4 timeless 2010-01-02 19:51:35 PST
Signature	nsPluginInstanceOwner::FixUpPluginWindow(int)
UUID	00f997c3-82e7-4849-8360-51b542091227
Time 	2009-12-27 17:34:14.519026
Uptime	709
Last Crash	715 seconds before submission
Product	Firefox
Version	3.5.6
Build ID	20091201203240
Branch	1.9.1
OS	Mac OS X
OS Version	10.5.8 9L30
CPU	ppc
CPU Info	
Crash Reason	EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE
Crash Address	0x121de4c
User Comments	While watching a product video the application just quit. This is the second time this has happened within 10 minutes.
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	nsPluginInstanceOwner::FixUpPluginWindow 	layout/generic/nsObjectFrame.cpp:4741
1 	XUL 	nsPluginInstanceOwner::Notify 	layout/generic/nsObjectFrame.cpp:4426
2 	XUL 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:423

1.408 <roc+@cs.cmu.edu> 2003-06-30 03:46 Ongoing deCOMtamination. r+sr=dbaron
4559 mOwner->GetView()->GetVisibility() == nsViewVisibility_kShow;

roc: can you shed some light on which things is likely unhappy? -- I'd bet on GetView() or its result, but...
Comment 5 Sheila Mooney 2012-02-22 16:22:17 PST
I found 2 crashes in the past 4 weeks, both on 3.6. I am going to resolve as fixed.

Note You need to log in before you can comment on or make changes to this bug.