Minotaur needs to check new Content Handling preferences for default handlers

RESOLVED FIXED

Status

defect
RESOLVED FIXED
12 years ago
Last year

People

(Reporter: cmtalbert, Assigned: cmtalbert)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

12 years ago
It is entirely feasible that future partner builds or L10N specific builds might use a different default than the "standard" default for the content/protocol handling pieces.  Minotaur should be updated to check these defaults and compare them during its verification process.
Assignee

Updated

11 years ago
Duplicate of this bug: 414010
Assignee

Comment 2

11 years ago
Posted patch Patch r1Splinter Review
I can't find a good way to break that regexp into multiple lines so that it fits the 80 character limit.  If you know of one, I'm all ears.  I've tried everything I can think of except using two different regexp's and concatenating the results (which seems like way too much work to simply satisfy the line length requirement.)

This outputs the default settings for the protocol handlers and it also outputs the places smartBookmark version which seems to be desired from bug 421483 comment 42 (https://bugzilla.mozilla.org/show_bug.cgi?id=421483#c42)
Assignee: nobody → ctalbert
Status: NEW → ASSIGNED
Attachment #314914 - Flags: review?(rcampbell)
Comment on attachment 314914 [details] [diff] [review]
Patch r1

I guess you could have multiple regexp objects. E.g., grabDist = /app\.distributor/;
grabPartner = /app\.partner/

and then match on each of them in the matching section below. That would be somewhat cumbersome though it would add to the understandability of each pref you're looking for. I dunno.
Attachment #314914 - Flags: review?(rcampbell) → review+

Comment 4

11 years ago
You could do a

var reStrings = ['(app\.distributor)',
                 '(app\.partner)',...];
var grab = new RegExp(reStrings.join('|'));
Assignee

Comment 5

11 years ago
I took Axel's suggestion and checked it in on trunk.
--> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Mass moving Minotaur bugs to Testing : Minotaur. Filter on MinotaurMassMove to ignore.
Component: Testing → Minotaur
Product: Core → Testing
QA Contact: testing → minotaur
Version: Trunk → unspecified

Updated

Last year
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.