Dragging some local files to the content area causes camino to hang

RESOLVED DUPLICATE of bug 397309

Status

--
critical
RESOLVED DUPLICATE of bug 397309
11 years ago
11 years ago

People

(Reporter: moz, Unassigned)

Tracking

({hang})

Trunk
x86
Mac OS X

Details

(Reporter)

Description

11 years ago
When I try to drag various files to the content area, Camino hangs.

Hangs:
.webloc
.url
.txt

Works:
.html/.html

Sampling shows infinite recursion between nsUnknownDecoder::OnStopRequest() and nsDocumentOpenInfo::OnStopRequest().

Seems like it hangs when files that Gecko doesn't handle itself are dropped, though that doesn't explain plain text files causing a hang...
(Reporter)

Comment 1

11 years ago
Whoops, added the wrong smorgan. :|
That is much the same as bug 395768 (focussed on .svg), except broader. When I checked that one bug, .txt files did load, though.

Atm, dragging .gif, .png, .jpg works fine.
.txt surprises me, too (.svg also breaks the "Gecko handles itself" pattern, since unless told otherwise, Gecko handles it, too)....

Wevah was getting a completely different sample than bug 395768, though, so I told him to file this separately.  (Also, this is a much nicer bug report.)
(Reporter)

Comment 4

11 years ago
(In reply to comment #0)

> Works:
> .html/.html

This should read ".html/.xhtml"; oops.
Can we get a sample here? I'm curious to know if this matches either bug 397300 or bug 397309.

Do we know if this is a problem on PPC as well?

cl

Comment 7

11 years ago
Yep, same thing; I'd forgotten about this one.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397309
You need to log in before you can comment on or make changes to this bug.