Created attachment 281209 [details] [diff] [review] patch for checkin Patch split off from bug 230870 (attachment 280259 [details] [diff] [review] which is r+ a1.9+), see bug 230870 comment 72 for naming. This is xs.7 and xs.8 for cleaning up the code path instead of doing Pause OR Resume -> PauseResume -> Pause OR Resume, it'll go Pause -> Pause and Resume -> Resume. Additionally, this fixes up various parts of the code to to use the refactored methods such as Cancel. Patch is applied after the one for bug 396453.
Comment on attachment 281209 [details] [diff] [review] patch for checkin For clarity, this is r=sdwilsh, a=mconnor
Checking in toolkit/components/downloads/src/nsDownloadManager.cpp; /cvsroot/mozilla/toolkit/components/downloads/src/nsDownloadManager.cpp,v <-- nsDownloadManager.cpp new revision: 1.120; previous revision: 1.119 done Checking in toolkit/components/downloads/src/nsDownloadManager.h; /cvsroot/mozilla/toolkit/components/downloads/src/nsDownloadManager.h,v <-- nsDownloadManager.h new revision: 1.44; previous revision: 1.43 done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.