Height of the menu bar (File, Edit, View, etc.) is too small (space above menu bar text cut too short)

RESOLVED FIXED

Status

()

Toolkit
XUL Widgets
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: reed, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 281316 [details]
comparison screenshot

The height of the menu bar (File, Edit, View, etc.) is too small on trunk as compared to branch (the space above the menu bar is cut short). For what I mean, see the screenshot for a comparison. Most GTK apps look like what Bon Echo has, so this change on trunk is a noticeable change that just looks ugly. I'll attempt to find a regression range for this.
(Reporter)

Updated

11 years ago
Component: Toolbars → XUL Widgets
Product: Firefox → Toolkit
QA Contact: toolbars → xul.widgets
(Reporter)

Comment 1

11 years ago
Looks like Neil's patch in bug 127244 caused this.
Blocks: 127244

Comment 2

11 years ago
This is cross-platform (one of the charmes of XUL...)
OS: Linux → All
Hardware: PC → All

Comment 3

11 years ago
Created attachment 282295 [details]
Screenshot of menubar problem in Nautipolis theme in Firefox

This is what happens in all my themes.
According to DOM Inspector the menubar is actually 10px high, but the
containing hbox has height 19px. Can someone explain me why this 'height:0' is
needed? 

See also bug 396565, comment 1:
Starting with the 2007-09-05-02 build, the menubar is not actually tall enough
for the text (or more precisely for the accesskey underlines).  Removing the
height="0" thing that bug 282188 added fixes the problem.

Comment 4

11 years ago
I've put what I believe is the fix in bug 396565; does anyone want to mess around with the dependencies/duplication?
(Reporter)

Comment 5

11 years ago
Fixed by the patch in bug 396565, afaik...
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.