If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Software-Update does not find any updates

VERIFIED DUPLICATE of bug 334136

Status

()

Toolkit
Application Update
--
minor
VERIFIED DUPLICATE of bug 334136
10 years ago
9 years ago

People

(Reporter: Fabian Troester, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

I have Firefox 2 running on several computer systems. Today I've got the notification about the update to version 2.0.0.7 on most systems but one. This same thing has happened on this single machine with every upgrade since the 2.0.0.5 upgrade.
My suspicion is: In July I had the Gran Paradiso Alpha 6 installed in parallel with then Firefox 2.0.0.4 and I used a different profile for each of them. After trying the Alpha version for a while, I removed it from my system (I uninstalled it).
Since then my Firefox installation on this particular system does no longer recognise any updates made available. Neither automatic update nor manual update works. I always have to download the complete software package (i.e. the new version of Firefox) and install it.
I tried to uninstall/reinstall Firefox in order to see if this helps. Still the same problem occurs.
Update of installed Extensions/Add-Ons works, though.
I am not sure if it's an actual bug or maybe my system is messed up.
Thank you.

Reproducible: Always

Steps to Reproduce:
1. As described above. A Firefox update is available.
2. Firefox dos not recognise it automatically.
3. Manual update via menu ... Firefox does not find any updates.
Actual Results:  
As described above. Software updates are not found.

Expected Results:  
Firefox recognises new updates available and offers download/install.

I use SpyBot S&D on my system (with TeaTimer), also Avira AntiVir (I don't know if this matters).

Installed Add-Ons:
Adblock Filterset.G Updater 0.3.1.1
Adblock Plus 0.7.5.1
Adblock Plus: Element Hiding Helper 1.0.2
Ctrl Tab Preview 0.2.1
DOM Inspector 1.8.1.6
DownThemAll! 0.9.9.10
Exif Viewer 1.27
Fission 0.8.8
Flashblock 1.5.4.1
IE Tab 1.3.3.20070528
Image Zoom 0.3
PopupMaster 1.2.1
Session Manager 0.6.1.4
Skype extension for Firefox 2.2.0.70
Tab Mix Plus 0.3.6
Toggle Search 0.5
UI Tweaker 1.7.0
UnPlug 1.6.06

Installed Themes:
Firefox (default) 2.0
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch
fabian, thanks for the detailed bug report.

on the firefox that will not upgrade, can you try the following:

1) start firefox, do about:config in the url bar
2) right click on the list of prefs and do "New | Boolean"
3) create a new boolean pref for app.update.log.Checker and set it to true
4) exit firefox and restart it
5) do Help | Check for Updates
6) open up the error console (under Tools)

copy and paste what you see in there to this bug report.

thanks!
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

10 years ago
Created attachment 281513 [details]
screenshot of error console
The locale code is de (rather than de-DE) for the installers available from mozilla.com, so this looks like a language pack. They don't get any updates yet, see bug 313453.
Oops, meant to say 334136, which should be fixed from 2.0.0.8 onwards.
(Reporter)

Comment 5

10 years ago
OK, I understand that. But I always used just the installers available from the mozilla.com site. I never installed a language pack.
And what's more: automatic software update did work including update from 2.0.0.3 to 2.0.0.4
I just started failing afterwards.
So maybe it is a misconfiguration of my Firefox installation?

(In reply to comment #3)
> The locale code is de (rather than de-DE) for the installers available from
> mozilla.com, so this looks like a language pack. They don't get any updates
> yet, see bug 313453.
> 

(Reporter)

Comment 6

10 years ago
Sorry, I meant: "It started failing ..." Typo. :-)
If you put about:config into the location bar, is the preference general.useragent.locale in bold (user set) with value de-DE? If your reset the pref what value to you get ? And do updates work then ?
(Reporter)

Comment 8

10 years ago
Oh, my. Now it works again! Thank you!

I reset it and got 'de'. Don't know how this happened. I certainly did not change the setting in the first place.

Thank you for your incredibly quick help.

What are the next steps? Should I set the bug report to 'fixed'?

(In reply to comment #7)
> If you put about:config into the location bar, is the preference
> general.useragent.locale in bold (user set) with value de-DE? If your reset the
> pref what value to you get ? And do updates work then ?
> 

FIXED is used when there is a code change as a result of the bug report. I'm going to dupe against the language pack bug I mentioned earlier because it's the same issue - ie the default value of general.useragent.locale should be used for update queries instead of whatever is set in the profile.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 334136
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.