Closed Bug 396770 Opened 17 years ago Closed 17 years ago

UA string in Help→About is broken into 4 parts, causing a vertical scrollbar (useragent, does not fit)

Categories

(Firefox :: General, defect, P5)

x86
Linux
defect

Tracking

()

RESOLVED FIXED
Firefox 3

People

(Reporter: Aleksej, Assigned: wladow)

References

Details

(Keywords: polish, regression)

Attachments

(4 files, 1 obsolete file)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007091904 Minefield/3.0a8pre


See the screenshot or:

Yesterdays build:

===
Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.9a8pre) Gecko/2007091804
Minefield/3.0a8pre
===

Todays build:

===
Mozilla/5.0 (X11; U; Linux i686;
en-US; rv:1.9a8pre)
Gecko/2007091904
=== (have to scroll down to see the next line)
Minefield/3.0a8pre


Apparently resulted from the checkins between 2007-09-18 23:34 and 2007-09-18 23:34.
Flags: blocking-firefox3?
Oops, well, that was a single check-in for several bugs at the mentioned time.
This could have changed because I checked in a change to make chrome (including this window) using high-quality text always, which means kerning and ligatures are enabled, which would change the text metrics for this text.

I think the real problem here is just that the window isn't sizing correctly.
Flags: blocking-firefox3? → blocking-firefox3+
Keywords: polish, regression
Target Milestone: --- → Firefox 3 M11
A suggestion that came up on IRC was to not have the user agent here at all -- for support purposes it's overly verbose, and it's easily obtainable via sites like http://whatsmyuseragent.com/ for those who are curious. [See also bug 401424, which looks like a modified user agent is causing a problem.]

The About dialog could probably get away with:

* Version ("2.0.0.8", "3.0a9pre", etc.). This is already present, right above the copyright statement.
* Build ID ("Gecko/2007110714"), to disambiguate nightlies.
* Maaaaaybe OS, as I can see that being a support issue for people who don't know what kind of computer they're using.

Perhaps just something like

    Firefox 3.0a9pre
Powered by Gecko/2007110714

and 
    Firefox 3.0
Powered by Gecko 1.9

Or do it like GTK apps normally do it:

   <b>Firefox 3.0</b>
Web Browser using Gecko 1.9

The OS bit seems to be irrelevant, a user who doesn't know which OS he/she is running normally doesn't ask for help on the internet.
I am against the OS bit removal, because I don’t want to have to type more (or worse — to post more comments) when commenting on bugs where only a trivial comment (WFM/confirmed/verified with <build>[ on <OS>]) is needed.

If you remove the OS bit, you can as well remove the ability to copy what is left then. Do neither.
PS to comment #6: Of course, it is often not the OS, but just a vague description of the platform the build is intended for, and the kernel platform it is running on, but it still is easier that way — remember all the times when someone posted a follow‐up comment to say what platform/OS they meant.
Priority: -- → P5
Target Milestone: Firefox 3 Mx → Firefox 3 M11
Keywords: access
this isn't a blocker, would be nice to fix, but readability of the UA string isn't really important (and it probably doesn't need to be in the about dialog at all)
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
What about replacing all instances of char / with spaces in this dialog? It can save a lot of place, because with this we will split longer words into two and lines can wrap better then. Look at Vista screenshot. UA string looks good in Vista even without patch, but it demonstrates that we saved one line with this patch, so it can fix the problem. Question is - what can happen if we modify UA here? Does this sound reasonable?  

I'll attach a patch if this is good to go.
Bug 414025 will partially fix this - it will drop last copyright sentence. However we still need set flex="1" for UA textbox, so more line can be visible. This patch sets margins for this textbox too.
Assignee: nobody → valastiak
Status: NEW → ASSIGNED
Attachment #299273 - Flags: review?(mano)
Attachment #299273 - Flags: review?(mano)
Attachment #299273 - Attachment is obsolete: true
Attachment #299766 - Flags: review?(mano)
For info for reviewer see comment #10. This patch was tested with ubuntu and archlinux too
Target Milestone: Firefox 3 beta3 → Firefox 3 beta4
Comment on attachment 299766 [details] [diff] [review]
make UA textbox flexible, set margins

r=mano
Attachment #299766 - Flags: review?(mano) → review+
Attachment #299766 - Flags: approval1.9?
Comment on attachment 299766 [details] [diff] [review]
make UA textbox flexible, set margins

a=mconnor on behalf of 1.9 drivers
Attachment #299766 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in browser/base/content/aboutDialog.css;
/cvsroot/mozilla/browser/base/content/aboutDialog.css,v  <--  aboutDialog.css
new revision: 1.10; previous revision: 1.9
done
Checking in browser/base/content/aboutDialog.xul;
/cvsroot/mozilla/browser/base/content/aboutDialog.xul,v  <--  aboutDialog.xul
new revision: 1.31; previous revision: 1.30
done
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 3 beta4 → Firefox 3
Depends on: 427047
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: