Closed Bug 396781 Opened 13 years ago Closed 4 years ago

automatic proxy detecting doesn't notice network changes (ie roaming laptop)

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1191253

People

(Reporter: jhaar, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

We use proxies within our work network, but when I suspend my laptop and take it home, firefox still thinks it's on the work network - and tries to use the work proxies instead of going out through my home proxy (yes, I have WPAD at home). So I end up with a "proxy server not found" type message.

To fix it, I can either restart firefox (in which case it detects the new settings), or change the network settings from "automatic proxy configuration URL" to "auto-detect" - or visa-versa - and reload a page. 

MSIE handles such changes just fine - but of course they have the advantage of being integrated into the OS so that the OS can tell MSIE whenever there's a network state change. 

I wonder if just getting Firefox to re-run it's "auto*" option instead of reporting the "proxy server unavailable" error would be a good fix? It certainly works when done by hand?


Reproducible: Sometimes

Steps to Reproduce:
1. start FF on one network. It auto-detects whether or not to use proxy correctly
2. suspend laptop and move to different network 
3. resume laptop and try to reload a web page - get "proxy server not available" (or "connection refused" if moving from a Direct Internet link to a firewalled-but-proxy network)
Actual Results:  
FF uses old network proxy configuration

Expected Results:  
FF should detect current network proxy configuration
see bug 43429 and bug 88218
auto-switching would be a more advanced solution
I must say I think those two references refer to different issues.

What I mean is that the current "code line" looks something like this:

if (fail to connect to proxy learnt by any form of auto-config)
then
      report error page
      stop
fi

and I propose it could be changed to 

if (fail to connect to proxy learnt by any form of auto-config)
then
       re-check network settings via new auto-config lookup
fi
if (fail to connect to proxy learnt by any form of auto-config)
then
      report error page
      stop
fi

I can confirm this bug. I usually put my laptop in "long standby" mode (I don't know the actual english term, only the french one "veille prolongée") and let firefox open. At work, we've got a corporate authenticated proxy.

When I wake it up at home, it won't autoconfigure until I restart Firefox or manually go inside the config panels to force FF to do it (exactly as described), and will just say the proxy wasn't found.

IMO, when in WPAD mode, FF should try to reinitialize/reconfigure using WPAD at least once before saying there's a problem when it can't find the proxy it previously found.

Cheers.
I can also confirm this. Is this bug abandoned? The proposal in comment 2 seems to me to be a pretty straight forward way to go, unless there are a lot of disadvantages not mentioned in the bug. It's currently very annoying that FF claims a proxy problem when I'm just in a new place..
With my configuration (FF 3.5.2) this also seems to happen when my computer goes in stand by (S3) and wakes up a few hours later. The behaviour of windows networking (xp) and firefox results in firefox losing it's proxy settings. In my case I can still browse, without advantages of the proxy.

Restarting firefox or killing the process with the task manager and using the session recovery stuff works to restore the proxy connection..
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.8 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INCOMPLETE
Firefox 33.0.2 on Windows 8.1, it still happens, have to do the exact same thing described in the original report to workaround this isue.
Reopening per the comment.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Version: 2.0 Branch → unspecified
7 years old bug and not solved till today. Hmmm... something wrong with firefox :/
yeah, I gave up in the end. Now I run my own squid proxy on my laptop, hardwire everything to use that, and then trigger my own automated reconfiguration of squid every time a network change is detected

Not really an "end user" solution but it works for me ;-)
Would really love to see this fixed - FF is used pervasively today across our enterprise, but as we're looking to do leverage pac file for roaming/mobile laptops, this bug is really throwing a wrench into the end user experience. Users have to manually close/re-open the browser, which is not always intuitive for less technically savvy individuals.
Whiteboard: [CLOSEME 2010-07-30]
(In reply to Tom F from comment #12)
> Would really love to see this fixed - FF is used pervasively today across
> our enterprise, but as we're looking to do leverage pac file for
> roaming/mobile laptops, this bug is really throwing a wrench into the end
> user experience. Users have to manually close/re-open the browser, which is
> not always intuitive for less technically savvy individuals.

Because of this bug, I use MM3 proxy switch browser addon to switch between proxy and non proxy without restarting FF.
Me too. Can't believe this bug was reported in 2008 and hasn't been attended to yet.
Manually resetting my network settings inside FF each time I have a problem, at the moment.
My employer are shortly going to make a change removing the requirement to use the proxy so i'm hanging out for the day when I won't need to deal to this anymore - but the bug is still annoying in the meantime.
This bug should be moved to Core -> Networking IMHO.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → Networking
Product: Firefox → Core
Hardware: x86 → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Closed: 10 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1191253
@Patrick McManus, this bug has nothing to do with Linux, so it's not a duplicate.
Very simply explained: on windows, when the option "Use system proxy settings" is chosen, when the system proxy exceptions change, firefox is not updated before restarting. A fix would be very welcome. Thanks.
Just to add to the previous comments. FF 51.0.1 is still showing the same behaviour. Work proxy with WPAD works fine. After suspend and start at home FF doesn't realise that the proxy has gone (e.g. a different client IP address may be a hint) and tries to connect to it even though windows and IE and Chrome all know that things have changed.
I've used foxyproxy in the past to manually switch between proxies, but it's a bit of overkill and it shouldn't really be required.
As far as I can tell this is not a duplicate of bug 1191253.
You need to log in before you can comment on or make changes to this bug.