Closed Bug 43429 Opened 23 years ago Closed 7 years ago

Proxy: Support multiple proxy configurations (in one profile)

Categories

(Core :: Networking, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Sebastian, Unassigned)

References

Details

(Keywords: helpwanted)

From n.p.m.wishlist:
"It would be nice to support multiple proxies within the same profile depending 
on the current ISP like IE5 does it."

It would be indeed a nice feature, however I don't know how feasible this is for 
two reasons: 
a) it would have to be handled totally different for different platforms and 
b) is mozilla aware of the type of network connection (ISP) it uses to connect?
   IE5 has in this case the advantage of being part of the OS.
Target Milestone: --- → Future
adding my proposals for an "advanced proxy support" from bug 59969:

- make mozilla auto detect, if the proxy uses http 1.0 or 1.1 (see bug 38488), (no
more debug prefs needed, which aren't available through "preferences" in ns6)

- support multiple proxy configurations, e.g. one config without proxys (direct
connection at home), one with a proxy (at work), another with a different proxy
(say, second ISP at home or a temporary configuration if you are on holidays
etc.). this would be really cool for laptop users! you should be able to apply
to the configurations through the preferences. i imagine a drop-down menu.

- do proxy configuration during profile creation
*** Bug 59969 has been marked as a duplicate of this bug. ***
Blocks: 61691
Taking bug.

> a) it would have to be handled totally different for different platforms

The user would have to manually select the ISP, until we have code that
intergrates with the OS. Still better than 2 profiles or manually changing
prefs. I suggest to use the offline function, i.e. turning the 2 states "online"
and "offline" into "offline", "custom" (uses proxies from user prefs) and once
for each provider.

The data (the proxies for each ISP and the ISP name) could (and should, at least
at some level) come from the ISP files, which we have in Mailnews anyway.
Assignee: gagan → ben.bucksch
*** Bug 59969 has been marked as a duplicate of this bug. ***
If anybody wants to fix this, take the bug.
mass move, v2.
qa to me.
QA Contact: tever → benc
can this bug can be fixed using PAC?
or maybe we need a way to tell which connection is being used? (that would be
platform specific I guess)
PAC solves it, but you have to keep changing the PAC URL in the Prefs UI.

This is another piece of functionality that fits under what I am proposing for
bug 89928.
*** Bug 88218 has been marked as a duplicate of this bug. ***
this bug is improtant for users who uses ad filter proxys.
mozilla should have more a status switch than a offline/online button to choose
which proxy or setting should be used. if you see that a wrong content is
filtered it is so complicated to turn of the proxy or select another.
Blocks: 88218
.
Keywords: helpwanted
(Dataloss during Back...)

->nobody
Assignee: ben.bucksch → nobody
Summary: [RFE] Multiple proxy for different ISPs → [RFE] Proxy: Multiple configs for different ISPs
*** Bug 148977 has been marked as a duplicate of this bug. ***
Summary: [RFE] Proxy: Multiple configs for different ISPs → Proxy: Multiple configs for different ISPs
I think this bug is several in one: there should be support for multiple 
preconfigered proxies. Proxy configs would have names and should be 
selectable easily and quickly.
The reason for this is that multiple ISPs is not the only reason for 
having several proxies - here are a few others: using a local ad/popup
filter proxy like privoxy or webwasher, using an anonymizer proxy like jap,
accessing a remote intranet server via a ssh tunnel which requires setting
the proxy to 127.0.0.1, using different proxies to speed up different groups
of web pages etc.
So having a means to easily and comfortably switch between preconfigured proxies
would be useful for all these situations *and* a first step to make it easier
to deal with different ISPs. 

Then, in a second step (and second bug?) we could add a feature to 
automatically select one of these proxies depending on the ISP.

One note about a portable way to implement that aut-selction: wouldn't it
be possible to do this based on a pattern of the own hostname and/or IP?
Taken to the most robust implementation, you are talking about bug 88218.
*** Bug 189746 has been marked as a duplicate of this bug. ***
*** Bug 199766 has been marked as a duplicate of this bug. ***
I've made some comments about how to store proxy config data (and implement
prefs UI) in bug 88218.
Summary: Proxy: Multiple configs for different ISPs → Proxy: Support multiple proxy configurations (in one profile)
Blocks: 138339
*** Bug 100523 has been marked as a duplicate of this bug. ***
No longer blocks: 88218
Depends on: 88218
I agree with the need for multiple proxy servers/configurations (ala DNS?). We
have three choices at the moment, automatic, manual, and direct connection. When
traipsing about the globe or just moving from office to home, it is frustrating
to have to keep looking up and manually changing the proxy server. I now have
four proxies that I must use regularly. Automatic proxy selection would be nice,
but even a drop-down list would be helpful.
Although I've yet to actually use it (installed, but not utilised), the Switch
Proxy extension looks to be quite useful in this sense.

http://jgillick.nettripper.com/switchproxy/
Blocks: 274693
*** Bug 274693 has been marked as a duplicate of this bug. ***
*** Bug 334810 has been marked as a duplicate of this bug. ***
NOTE: many users simply need a SECOND proxy "profile", because they use different proxies at home vs. work.

Using a simple PAC file can get you around that.
Priority: P3 → --
Target Milestone: Future → ---
This isn't on anyone's work list and realistically is an abandoned idea. I will close as wontfix - if someone has a patch or is actively going to work on it please reopen. (but please, only then.)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.