Last Comment Bug 397006 - Thunderbird crash on exit [@ morkArray::closeArray() ]
: Thunderbird crash on exit [@ morkArray::closeArray() ]
Status: RESOLVED DUPLICATE of bug 374240
: crash
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 2.0
: x86 Linux
-- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 20:30 PDT by Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention)
Modified: 2011-06-09 14:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2007-09-20 20:30:05 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007092002 Firefox/3.0a8pre SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8pre) Gecko/20070920 Thunderbird/2.0.0.7pre - Build ID: 2007092004

TB36121956G


Reproducible: Didn't try

Actual Results:  
crash

Expected Results:  
normal closedown

I'm not sure but I think that this bug might be related but not identical to bug 374240

Here comes the Talkback report:

Incident ID: 36121956
Stack Signature	morkArray::CloseArray() cc1e017b
Product ID	Thunderbird2
Build ID	2007092004
Trigger Time	2007-09-20 20:02:25.0
Platform	LinuxIntel
Operating System	Linux 2.6.18.8-0.5-default
Module	thunderbird-bin + (000b67d3)
URL visited	
User Comments	closing Thunderbird
Since Last Crash	5 sec
Total Uptime	5 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	/builds/tinderbox/Tb-Mozilla1.8.0/Linux_2.4.18-14_Depend/mozilla/db/mork/src/morkArray.cpp, line 223
Stack Trace 	
morkArray::CloseArray()  [mozilla/db/mork/src/morkArray.cpp, line 223]
morkArray::CloseMorkNode()  [mozilla/db/mork/src/morkArray.cpp, line 254]
morkTable::CloseTable()  [mozilla/db/mork/src/morkTable.cpp, line 189]
morkTable::CloseMorkNode()  [mozilla/db/mork/src/morkTable.cpp, line 254]
morkTable::~morkTable()  [mozilla/db/mork/src/morkTable.cpp, line 240]
morkObject::Release()  [mozilla/db/mork/src/morkObject.cpp, line 67]
nsCOMPtr_base::~nsCOMPtr_base()  [mozilla/xpcom/build/nsCOMPtr.cpp, line 81]
nsMsgDBEnumerator::~nsMsgDBEnumerator()  [mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 2625]
nsMsgDBEnumerator::Release()  [mozilla/mailnews/db/msgdb/src/nsMsgDatabase.cpp, line 2627]
XPCJSRuntime::GCCallback()  [mozilla/js/src/xpconnect/src/xpcjsruntime.cpp, line 587]
DOMGCCallback()  [mozilla/dom/src/base/nsJSEnvironment.cpp, line 2272]
js_GC()  [mozilla/js/src/jsgc.c, line 3179]
JS_GC()  [mozilla/js/src/jsapi.c, line 1879]
nsXREDirProvider::DoShutdown()  [mozilla/toolkit/xre/nsXREDirProvider.cpp, line 684]
ScopedXPCOMStartup::~ScopedXPCOMStartup()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 759]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 2771]
main()  [mozilla/mail/app/nsMailApp.cpp, line 63]
libc.so.6 + 0x15f9c (0xb7242f9c)
Comment 1 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2007-09-20 20:34:31 PDT
adding a few Cc to check (prove/disprove) the parency mentioned in comment #0
Comment 2 User image David :Bienvenu 2007-09-20 20:48:27 PDT
yeah, probably the same problem, which should be fixed on the trunk...
Comment 3 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2007-09-20 20:56:06 PDT
(In reply to comment #2)
> yeah, probably the same problem, which should be fixed on the trunk...
> 
- Any idea if/when the port will be ported to trunk?
- Do you think these bugs are close enough for a dupe?
Comment 4 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2007-09-20 20:56:44 PDT
oops... I meant, ported to the branch
Comment 5 User image David :Bienvenu 2007-09-21 08:12:56 PDT
I've requested approval for a branch checkin - don't know when I might get it...

I'd say they're dups - I don't know for sure that the patch will make the problems go away for everyone, though it did help the reporter of the other bug
Comment 6 User image Tony Mechelynck [:tonymec]. (NEEDINFO me if you want my attention) 2007-09-21 15:20:22 PDT
(In reply to comment #5)
[...]
> I'd say they're dups - I don't know for sure that the patch will make the
> problems go away for everyone, though it did help the reporter of the other bug
> 

OK. I'm marking it tentatively as dupe; if the one remains after the other is fixed and the fix ported, let whoever gets bitten reopen or report anew.

*** This bug has been marked as a duplicate of bug 374240 ***

Note You need to log in before you can comment on or make changes to this bug.