Last Comment Bug 397150 - Spellchecking dictionary is not sufficiently licensed
: Spellchecking dictionary is not sufficiently licensed
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla1.9beta2
Assigned To: Kevin Atkinson
:
Mentors:
http://mxr.mozilla.org/mozilla/source...
Depends on: hunspell
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-22 00:38 PDT by Hasse
Modified: 2008-03-28 08:03 PDT (History)
23 users (show)
dsicore: blocking1.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Copyright for Aspell English Dictionary (10.96 KB, text/plain)
2007-11-10 11:09 PST, Kevin Atkinson
no flags Details
New en_US dictionary for Hunspell (210.74 KB, application/zip)
2007-11-23 00:47 PST, Kevin Atkinson
no flags Details
New en_CA dictionary for Hunspell (211.29 KB, application/zip)
2007-11-23 00:48 PST, Kevin Atkinson
no flags Details
New en_US dictionary for Hunspell (210.82 KB, application/zip)
2007-11-24 21:03 PST, Kevin Atkinson
no flags Details
README_mozilla.txt (375 bytes, text/plain)
2007-11-28 19:49 PST, Ryan VanderMeulen [:RyanVM]
no flags Details
mozilla_words.diff (3.15 KB, patch)
2007-11-28 19:50 PST, Ryan VanderMeulen [:RyanVM]
no flags Details | Diff | Splinter Review

Description Hasse 2007-09-22 00:38:59 PDT
The Readme file for the en-US dictionary says:
----
This dictionary is based on a subset of the original
English wordlist created by Kevin Atkinson for Pspell 
and  Aspell and thus is covered by his original 
LGPL license.
----

Since the only licenses permitted in Mozilla products are the MPL/GPL/LGPL tri-license or a BSD-style license, the dictionary needs to be relicensed or removed from CVS.
Comment 1 Gervase Markham [:gerv] 2007-09-29 10:18:30 PDT
Is this a side-effect of us changing spell-checking engines? I'm sure the license for our en-US dictionary used to be OK...

Gerv
Comment 2 Robert Kaiser 2007-10-02 12:05:04 PDT
Yes, that's probably a side effect of the change to hunspell...
Comment 3 Németh László 2007-10-03 06:18:57 PDT
(In reply to comment #2)
> Yes, that's probably a side effect of the change to hunspell...
> 

This is not a Hunspell related issue.
Hunspell uses the original MySpell en_US dictionary, similar to Mozilla.
See http://lingucomponent.openoffice.org/MySpell-3.zip and en-US in
Mozilla source code.

The original license:
======== README_en_US.txt ============7
This dictionary is based on a subset of the original 
English wordlist created by Kevin Atkinson for Pspell 
and  Aspell and thus is covered by his original 
LGPL license.  The affix file is a heavily modified
version of the original english.aff file which was
released as part of Geoff Kuenning's Ispell and as 
such is covered by his BSD license.

Thanks to both authors for there wonderful work.
==========================================


Comment 4 Németh László 2007-10-03 06:20:29 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > Yes, that's probably a side effect of the change to hunspell...
> > 
> 
> This is not a Hunspell related issue.
> Hunspell uses the original MySpell en_US dictionary, similar to Mozilla.
> See http://lingucomponent.openoffice.org/MySpell-3.zip and en-US in
> Mozilla source code.
> 
> The original license:
> ======== README_en_US.txt ============7
> This dictionary is based on a subset of the original 
> English wordlist created by Kevin Atkinson for Pspell 
> and  Aspell and thus is covered by his original 
> LGPL license.  The affix file is a heavily modified
> version of the original english.aff file which was
> released as part of Geoff Kuenning's Ispell and as 
> such is covered by his BSD license.
> 
> Thanks to both authors for there wonderful work.
> ==========================================
> 

But maybe there is a solution for the license problem.
Comment 5 Hasse 2007-10-13 08:29:22 PDT
(In reply to comment #1)
> Is this a side-effect of us changing spell-checking engines? I'm sure the
> license for our en-US dictionary used to be OK...

Isn't some sort of supporting evidence needed here?

Bug 227214, comment#3 seems to suggest that the Myspell dictionary used in Fx2 and Tb2 is LGPL.
Comment 6 Daniel Veditz [:dveditz] 2007-10-21 16:53:28 PDT
LGPL should be fine for something that isn't a linked-in binary, isn't it? In any case we're not going to resolve this in a security-update release time-frame. If we come to a trunk resolution that requires a branch change we can think about it at that time.
Comment 7 Gervase Markham [:gerv] 2007-10-27 04:01:40 PDT
(In reply to comment #6)
> LGPL should be fine for something that isn't a linked-in binary, isn't it?

The issue is not that we are in violation of any license, but that our policy is designed so that distributors can take all the code we ship under any one of the three licences (or compatible terms, such as BSD). Having an LGPL component means that this is no longer true for the MPL.

> In
> any case we're not going to resolve this in a security-update release
> time-frame. If we come to a trunk resolution that requires a branch change we
> can think about it at that time.

OK.

Gerv

Comment 8 bjoern 2007-11-02 08:28:08 PDT
Why do you make yourself life so hard?
It's not required to add dictionaries into the *code base*. It is sufficient to add the dictionaries to the installer packages. And for this case even the FSF says that GPL dictionaries are fine to be included into non-GPL Software. All you need to do is write at apropriate place the licenses that the additional components have.
Comment 9 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2007-11-02 08:33:28 PDT
Bjoern, our installers are created from our codebase.
Comment 10 bjoern 2007-11-02 11:18:40 PDT
then you should maybe try to extend it. Additional patches from outside your main codebase should be possible to be added.
Comment 11 Gervase Markham [:gerv] 2007-11-03 04:52:22 PDT
Whether it's in our code repository or not is not really the question. We want to be able to say to people who make derivative browsers: "Comfortable with the MPL? OK, great, you can ship any of our code, up to and including something that is as functional as Firefox but with a new name."

This is currently not true due to the dictionary issue.

Gerv
Comment 12 Damon Sicore (:damons) 2007-11-08 18:11:03 PST
We need to decide about this.  +'ing.
Comment 13 Damon Sicore (:damons) 2007-11-09 15:41:03 PST
Let's not ship another release until this is fixed.  Marking P1.
Comment 14 Kevin Atkinson 2007-11-10 11:07:58 PST
Hi.

I can not speak for the en_US dictionary however the, the Aspell dictionary is under the following copyright, not the LGPL:

The collective work is Copyright 2000-2004 by Kevin Atkinson as well
as any of the copyrights mentioned below:

  Copyright 2000-2004 by Kevin Atkinson

  Permission to use, copy, modify, distribute and sell these word
  lists, the associated scripts, the output created from the scripts,
  and its documentation for any purpose is hereby granted without fee,
  provided that the above copyright notice appears in all copies and
  that both that copyright notice and this permission notice appear in
  supporting documentation. Kevin Atkinson makes no representations
  about the suitability of this array for any purpose. It is provided
  "as is" without express or implied warranty.

Since it is a derived work it is under many other copyrights but they are all BSD like.  I will attach the Copyright file.

I did not write the affix file so I can not speak for it.



Comment 15 Kevin Atkinson 2007-11-10 11:09:35 PST
Created attachment 288156 [details]
Copyright for Aspell English Dictionary
Comment 16 Robert Kaiser 2007-11-10 13:12:35 PST
Is the HunSpell dictionary we use the same as or derived from the Aspell one? If not, mentioning of licensing of the latter probably is just useless here.
Comment 17 Ryan VanderMeulen [:RyanVM] 2007-11-10 15:07:35 PST
From what I'm reading in this thread and the licenses, it seems that maybe saying that the en_US dictionary is under LGPL license is a misnomer. If the original Aspell dictionary is under a BSD-like license and Nemeth says in the readme that the dictionary falls under the original license, that tells me that the dictionary should be under a BSD-like license, not LGPL. If that's the case, is there a problem here? The BSD license grants more freedoms anyway.

Am I misunderstanding?
Comment 18 Steffen Wilberg 2007-11-11 02:05:57 PST
(In reply to comment #16)
> Is the HunSpell dictionary we use the same as or derived from the Aspell one?
It's derived from it, see http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/extensions/spellcheck/locales/en-US/hunspell/README.txt&rev=1.1&mark=4-12 :
> This dictionary is based on a subset of the original
> English wordlist created by Kevin Atkinson for Pspell 
> and  Aspell and thus is covered by his original 
> LGPL license.  The affix file is a heavily modified
> version of the original english.aff file which was
> released as part of Geoff Kuenning's Ispell and as 
> such is covered by his BSD license.
> 
> Thanks to both authors for there wonderful work.

I guess all we have to do is:
1. Fix the above hunspell readme: s/LGPL/BSD-like/
2. Add the copyright notice from comment 14 for the dictionary.
3. Confirm that Ispell is indeed under a BSD license, and add the copyright notice for the affix file to about:license (mozilla/toolkit/content/license.html).
Comment 19 Kevin Atkinson 2007-11-11 02:14:27 PST
Please note, that I do not know what specific dictionary version the en_US is derived from since I did not create it.  The Copyright I attached is for the latest Aspell dictionary.

I can easily create an new en_US dictionary from the latest Aspell dictionary if it will help.
Comment 20 Gervase Markham [:gerv] 2007-11-12 14:18:53 PST
Steffen: you can't do 1) if anyone else has made contributions to the dictionary since it was derived from the Aspell one. So you need to check that, and ask their permission if there any such people.

I'd prefer it if we didn't have to add enormous screeds of text to about:licence. And that wouldn't be appropriate anyway because the dictionary isn't shipped in all builds. Can we ship the info in a LICENSE file which gets installed next to the dictionary?

Gerv
Comment 21 Robert Kaiser 2007-11-13 06:34:00 PST
(In reply to comment #20)
> Can we ship the info in a LICENSE file which gets
> installed next to the dictionary?

If so, could we use such an approach for other languages than en-US as well?
If not, should we place the dictionaries in other-licenses/ and package them from there?
Comment 22 Gervase Markham [:gerv] 2007-11-14 13:21:50 PST
This bug is really hard to understand. Perhaps it's because I don't understand the structure of these dictionaries, but if someone could post a clear explanation of the relationship between the Aspell, Pspell, Ispell and Hunspell dictionaries, that would help. They should pay particular attention to the difference, if any, between the sources of wordlists and affix files, and how these combine together to make a "dictionary".

Still, with my current understanding, I suggest the steps to resolve this are:

1) Check whether anyone has added to the Hunspell dictionary since it was derived from the Aspell one.
2) If they have, we need to either re-derive a new copy without their changes, or get those people's permission for a "change", because they may have contributed under the impression the file was LGPL. This will give us an en-US dictionary which is unambiguously BSD-licensed.
3) Change the README as outlined in comment 18, points 1 and 2.
4) Make sure that when we ship the en-US dictionary, the README is shipped along with it (in the same directory). This fulfils the requirement of the BSD licences (e.g. the one quoted in comment 14).

Kairo: No. My suggestion is only to solve a practical problem; it is not a route to shipping non-tri-license-compatible dictionaries.

Gerv
Comment 23 Kevin Atkinson 2007-11-14 15:18:01 PST
Hi, 

I am the author of Aspell.  The en_US dictionary is based on an old Aspell dictionary.  I do not know which one since I did not create it.  Nor do I know what changes where made.

However, I already talked with Németh László and I plan on taking over as the maintainer of the en_US dictionary.  As such I am going to be recreating the en_US dictionary from SCOWL.  This way the Copyright will be clear.  It is will be under the copyright attached in comment 15.

I plan to create a new dictionary in the next week or so.
Comment 24 Németh László 2007-11-14 15:45:05 PST
(In reply to comment #23)
Hi,

First, many thanks for your help.

Kevin Hendricks, author of MySpell used an old LGPL version of your Aspell en_US dictionary in end of 2001. It would be a quick solution for Mozilla, if you and Kevin Hendricks could give BSD or MPL/LGPL/GPL tri-licence for the MySpell/Hunspell en_US, too. Also I release my Hunspell related modifications (some definitions for ordinal number recognition and obscene suggestion filtering) under BSD license. There are also some new words in Hunspell en_US from OpenOffice.org and Mozilla issues, added by Daniel Naber and me. 

Your new dictionary would be a great help and a long-term solution for maintaining. Thanks in advance.


Comment 25 Kevin Atkinson 2007-11-23 00:47:06 PST
Created attachment 289897 [details]
New en_US dictionary for Hunspell
Comment 26 Kevin Atkinson 2007-11-23 00:48:38 PST
Created attachment 289898 [details]
New en_CA dictionary for Hunspell
Comment 27 Kevin Atkinson 2007-11-23 00:58:59 PST
I have attached a preliminary version of the en_US and en_CA dictionary for Hunspell generated from SCOWL under a BSD like copyright.

Some additions to the en_US from OpenOffice.org and Mozilla issues are likely to have been lost.  Please submit suggestions for improvements to the Issue Tracker found at http://sourceforge.net/tracker/?group_id=10079&atid=1014602
Comment 28 Magnus Melin 2007-11-23 09:13:10 PST
The mozilla additions to en-US should be (only) those in bug 339123.
Comment 29 Kevin Atkinson 2007-11-24 21:03:41 PST
Created attachment 290079 [details]
New en_US dictionary for Hunspell

This new dictionary addresses many, but not all, of the issues in bug 339123.  For example I did not add the words "Seamonkey" and "http" (but added "Firefox" and "Mozilla", and "HTTP" is already in there).  If you don't agree with me please submit to the Issue Tracker at http://sourceforge.net/tracker/?group_id=10079&atid=1014602.
Comment 30 Robert Kaiser 2007-11-25 05:39:05 PST
Not adding "SeaMonkey" would be a blocker bug of the dictionary. You should either add all the words that are in bug 339123 or don't even try to get it into our tree. It's ridiculous to follow what we need only half-way.
Comment 31 Brett Wilson 2007-11-25 08:08:55 PST
Please be more respectful of Kevin's great work. He gave you the correct way to complain if you don't agree. Why should he add random, not very popular brand names? I am the author of the list in bug 339123, and if I was maintaining a spellchecker, I would probably make the same call (adding the popular open source brands, but not the less popular ones).

Each word added to the dictionary has a cost associated with it that it could be marked correct when not desired (imagine a school kind trying to spell "sea monkey") or when it is suggested inappropriately.  Mozilla can always add more of their own, like we always have.

The patch in that bug is Mozilla licensed, so it can be applied to the new list without any problems.
Comment 32 Robert Kaiser 2007-11-25 09:06:20 PST
I only meant that all those need to be added to the copy in our source code, I couldn't care less about the dict distributed with something else, but we ship the mozilla.org copy with SeaMonkey and suddenly missing our own MoFo brand names, including the name of our own app in the dictionaries we ship ourselves would suck hard. My comment was completely about the copy we should include in our mozilla.org repo, not about anything distributed somewhere else, as this bug is only about stuff in Mozilla, not about other projects.
Comment 33 Kevin Atkinson 2007-11-25 14:33:27 PST
I do not plan to create a Mozilla specific dictionary.  What I attached in a updated generic Hunspell dictionary, one which is of higher quality than the version you had.  Like Brett Wilson said, you can always add those words yourself.

Of course if you make non-Mozilla specific changes I would like to know about them.

Eventually I will distribute the generic Hunspell version at http://wordlist.sourceforege.net.
Comment 34 Kevin Atkinson 2007-11-25 14:45:42 PST
Make that: http://wordlist.sourceforge.net/

Sorry.
Comment 35 Frank Hecker 2007-11-26 05:03:42 PST
I've read through the comments above, and based on that here is my understanding; please anyone feel free to correct me if I am wrong.

1. The new en_US dictionary attached to the bug by Kevin Atkinson resolves any lingering questions about the licensing of the old dictionary previously being used in Mozilla-based products. We therefore definitely want to use this dictionary in preference to the older ones. (And thank you, Kevin, for the work you put into both creating it and addressing the licensing questions.)

2. As maintained and distributed by Kevin this dictionary is a generic dictionary which will be used in non-Mozilla products as well. It includes entries for "Mozilla", "Firefox", and "Thunderbird", but does not include other words that are Mozilla Foundation trademarks or otherwise associated with the Mozilla project; examples of these omitted words include "Bugzilla", "Camino", "Gecko", "SeaMonkey", and others.

3. If we wish to include these other Mozilla-specific words in dictionaries shipped with Mozilla-based products then we can take the generic dictionary from Kevin Atkinson (as attached to the bug) and then make these Mozilla-specific changes to a Mozilla-specific copy of the dictionary in the Mozilla source tree. 

If I am correct in my understanding then the above seems a reasonable approach as far as I'm concerned.
Comment 36 Németh László 2007-11-26 05:35:35 PST
(In reply to comment #35)
> I've read through the comments above, and based on that here is my
> understanding; please anyone feel free to correct me if I am wrong.
> 
> 1. The new en_US dictionary attached to the bug by Kevin Atkinson resolves any
> lingering questions about the licensing of the old dictionary previously being
> used in Mozilla-based products. We therefore definitely want to use this
> dictionary in preference to the older ones. (And thank you, Kevin, for the work
> you put into both creating it and addressing the licensing questions.)
> 
> 2. As maintained and distributed by Kevin this dictionary is a generic
> dictionary which will be used in non-Mozilla products as well. It includes
> entries for "Mozilla", "Firefox", and "Thunderbird", but does not include other
> words that are Mozilla Foundation trademarks or otherwise associated with the
> Mozilla project; examples of these omitted words include "Bugzilla", "Camino",
> "Gecko", "SeaMonkey", and others.
> 
> 3. If we wish to include these other Mozilla-specific words in dictionaries
> shipped with Mozilla-based products then we can take the generic dictionary
> from Kevin Atkinson (as attached to the bug) and then make these
> Mozilla-specific changes to a Mozilla-specific copy of the dictionary in the
> Mozilla source tree. 
> 
> If I am correct in my understanding then the above seems a reasonable approach
> as far as I'm concerned.
> 

Quite so. The new dictionary works well with Hunspell. Many thanks to Kevin to solve this longstanding problem.
Comment 37 Frank Hecker 2007-11-26 08:24:41 PST
(In reply to comment #36)
> Quite so. The new dictionary works well with Hunspell. Many thanks to Kevin to
> solve this longstanding problem.

My thanks again as well.

As far as I am concerned we now have a suitable plan of action to resolve this bug, i.e., to accept the new dictionary into the Mozilla tree, and then (if we wish) to make further Mozilla-specific changes to the Mozilla copy of the dictionary in order to add Mozilla-specific terms. The former action can be undertaken to resolve this bug, and the latter action can be done in the context of a separate bug, either bug 339123 (if it's reopened) or a new bug.

Gerv, what say you?
 

Comment 38 Gervase Markham [:gerv] 2007-11-26 10:29:09 PST
Sounds good. Please check in these new dictionaries (for various variants of en; is there an en_GB one?) and file new bugs for:

- Any licensing changes or text required (and I'll figure out in that bug how to do that, if we're not shipping this with all copies)

- Any updates required to the dictionary/ies to make them better suited for Mozilla project use.

Perhaps someone could diff the old and new dictionaries, and see whether there are any other non-Mozilla mods that got made somewhere along the way. Then, we can figure out who made them, and try and get those improvements included too.

Gerv
Comment 39 Kevin Atkinson 2007-11-26 12:36:45 PST
I can create an en_GB dictionary if you want one.  However, unlike the en_US and en_CA the en_GB dictionary has diverged significantly from SCOWL.  The en_GB dictionaries available at http://wiki.services.openoffice.org/wiki/Dictionaries are now probably considered of much higher quality than the en_GB dictionary I can create.
Comment 40 Reed Loden [:reed] (use needinfo?) 2007-11-26 12:46:22 PST
(In reply to comment #38)
> Sounds good. Please check in these new dictionaries

Does somebody need to review them first, or should they just be checked-in?
Comment 41 Kevin Atkinson 2007-11-26 12:51:13 PST
Reed Loden has assigned this bug to me.  Not sure what that means.  Please note, I have no intention of checking them in or maintain the Mozilla specific dictionary (only the generic one).  I will leave that up to someone else.

Comment 42 Reed Loden [:reed] (use needinfo?) 2007-11-26 13:16:07 PST
(In reply to comment #41)
> Reed Loden has assigned this bug to me.  Not sure what that means.  Please
> note, I have no intention of checking them in or maintain the Mozilla specific
> dictionary (only the generic one).  I will leave that up to someone else.

I assigned it to you because you submitted the new dictionaries. Don't worry about checking them in or maintaining Mozilla-specific changes. As soon as I get an answer to comment #40, I can check them in. Thanks for all the work with regards to the dictionaries!
Comment 43 Ryan VanderMeulen [:RyanVM] 2007-11-26 16:40:50 PST
I can take care of making a new patch for the Mozilla-specific words if you guys want.
Comment 44 Brendan Eich [:brendan] 2007-11-26 21:25:17 PST
Reed, unless you are prepared to "review" the dictionaries (spot check, I presume you are not going to read every word), I think we should just take them. Anyone who feels motivated can review after.

/be
Comment 45 Robert Kaiser 2007-11-27 06:30:38 PST
(In reply to comment #43)
> I can take care of making a new patch for the Mozilla-specific words if you
> guys want.

Thanks, because I'd consider not having them in a regression I would request any blocking flag for without hesitation ;-)
Comment 46 Ryan VanderMeulen [:RyanVM] 2007-11-28 19:49:18 PST
Created attachment 290640 [details]
README_mozilla.txt

README for the mozilla_words.diff file.
Comment 47 Ryan VanderMeulen [:RyanVM] 2007-11-28 19:50:48 PST
Created attachment 290641 [details] [diff] [review]
mozilla_words.diff

New mozilla_words.diff for en_US Hunspell dictionary. If I'm missing any words, let me know and I can submit a new one.
Comment 48 Reed Loden [:reed] (use needinfo?) 2007-11-28 22:46:07 PST
Thank you Kevin and Ryan both!

Checking in extensions/spellcheck/locales/en-US/hunspell/README.txt;
/cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/README.txt,v  <--  README.txt
new revision: 1.2; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/README_mozilla.txt,v
done
Checking in extensions/spellcheck/locales/en-US/hunspell/README_mozilla.txt;
/cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/README_mozilla.txt,v  <--  README_mozilla.txt
initial revision: 1.1
done
Checking in extensions/spellcheck/locales/en-US/hunspell/en-US.aff;
/cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/en-US.aff,v  <--  en-US.aff
new revision: 1.2; previous revision: 1.1
done
Checking in extensions/spellcheck/locales/en-US/hunspell/en-US.dic;
/cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/en-US.dic,v  <--  en-US.dic
new revision: 1.2; previous revision: 1.1
done
RCS file: /cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/mozilla_words.diff,v
done
Checking in extensions/spellcheck/locales/en-US/hunspell/mozilla_words.diff;
/cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/mozilla_words.diff,v  <--  mozilla_words.diff
initial revision: 1.1
done

Checking in extensions/spellcheck/locales/en-US/hunspell/en-US.dic;
/cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/en-US.dic,v  <--  en-US.dic
new revision: 1.3; previous revision: 1.2
done
Checking in extensions/spellcheck/locales/en-US/hunspell/mozilla_words.diff;
/cvsroot/mozilla/extensions/spellcheck/locales/en-US/hunspell/mozilla_words.diff,v  <--  mozilla_words.diff
new revision: 1.2; previous revision: 1.1
done
Comment 49 Reed Loden [:reed] (use needinfo?) 2007-11-29 08:33:11 PST
So, can extensions/spellcheck/locales/en-US/myspell/ be cvs removed since it's no longer being used?
Comment 50 Ryan VanderMeulen [:RyanVM] 2007-11-29 15:07:12 PST
Yes, see bug 403347
Comment 51 Daniel Veditz [:dveditz] 2008-01-07 15:52:50 PST
This seems sufficiently fixed on the trunk, do we need to fix it on the branch?
Comment 52 Frank Hecker 2008-01-12 18:03:06 PST
As I understand it from Gerv's comments above (e.g., comment #7), a major motivation for making this change was to make licensing simple for downstream licensees creating their own distributions. Since a number of downstream licensees are shipping distributions based on the branch (and will be for some time to come), perhaps it makes sense to make the fix on the branch as well, if it's a sufficiently low-risk change. But maybe we need input from some distributors here?
Comment 53 Axel Hecht [:Pike] 2008-03-28 04:41:03 PDT
Kevin, the dictinaries that you attached only say "hunspell", I'm wondering, do they work with myspell, too? That'd be a prerequisit of being able to fix this on the branch, which dveditz and Frank talked about in the previous two comments.
Comment 54 Németh László 2008-03-28 08:03:59 PDT
(In reply to comment #53)
Attached dictionaries are Myspell compatible. (But I just downloaded the en_US dictionary extension by Firefox 3b4, and it uses Hunspell's affix compression for smaller memory footprint. Alias compression switches off the affixation in Myspell, so I hope, there is also a full Myspell compatible extension on Firefox Add-on Page for Firefox 2.)

Note You need to log in before you can comment on or make changes to this bug.