hidden form input fields are visible when inputs are set to display: block and padding is added to inputs

RESOLVED DUPLICATE of bug 436046

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 436046
10 years ago
8 years ago

People

(Reporter: Steven Bakhtiari, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070801 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070801 Firefox/2.0.0.6

Setting display: block on form input elements makes hidden inputs visible. Having set a background colour on the form, the hidden field was made visible, only because of padding added to the input elements. Padding or not, the element should not be visible. It should not be rendered at all.

Reproducible: Always

Steps to Reproduce:
1. Create form with at least 1 hidden input
2. Set padding and display: block to form inputs
3. Set a background colour, other than white, for the form.
Actual Results:  
You will see a white line where the padding has been added to the hidden input.

Expected Results:  
There should be no sign of hidden input elements.
(Reporter)

Comment 1

10 years ago
Created attachment 281930 [details]
HTML test case
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch

Comment 2

9 years ago
Yes, I can reprocedure this bug in Firefox 3.0. Here my user-agent:
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0

I signup here to request this bug, but Steven was faster :)
BTW, my workaround now is a CSS-Style in the input-tag: style="display:none;".

cu,
Jens

Comment 3

9 years ago
you can use this workaround for now:

input[type=hidden]
{
    display: none !important;
}

..dont like inline-styles ;)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 436046
You need to log in before you can comment on or make changes to this bug.