Closed Bug 397180 Opened 12 years ago Closed 7 years ago

South African Holidays 2013

Categories

(Calendar :: Website, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 728667

People

(Reporter: ralph, Assigned: ralph)

Details

Attachments

(1 file, 4 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 

I can't find anyway to attached the .ics files, so here it is ...

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
BEGIN:VTIMEZONE
TZID:/mozilla.org/20070129_1/Africa/Johannesburg
X-LIC-LOCATION:Africa/Johannesburg
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0200
TZNAME:SAST
DTSTART:19700101T000000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20070922T180435Z
LAST-MODIFIED:20070922T180503Z
DTSTAMP:20070922T181509Z
UID:07232483-dd9e-4f59-8788-b667ef4186c0
SUMMARY:New Year's Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080101
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080102
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T180507Z
LAST-MODIFIED:20070922T180539Z
DTSTAMP:20070922T181509Z
UID:ef34b3e8-5944-48f2-bcf4-9435eefb86d7
SUMMARY:Human Rights Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080321
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080322
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T180705Z
LAST-MODIFIED:20070922T180730Z
DTSTAMP:20070922T181509Z
UID:e61bac9a-7895-4b63-8db6-cf75e15d5a1d
SUMMARY:Family Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080409
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080410
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T180738Z
LAST-MODIFIED:20070922T180755Z
DTSTAMP:20070922T181509Z
UID:b3dad871-8487-4ef3-a6f8-4bf464147334
SUMMARY:Freedom Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080427
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080428
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T180833Z
LAST-MODIFIED:20070922T180854Z
DTSTAMP:20070922T181509Z
UID:97d20376-3882-48d8-95b4-f0a09b04af24
SUMMARY:Workers' Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080501
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080502
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T180904Z
LAST-MODIFIED:20070922T180926Z
DTSTAMP:20070922T181509Z
UID:02e2458f-2af0-4130-9bfe-0e73cdc8749a
SUMMARY:Youth Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080616
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080617
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T180937Z
LAST-MODIFIED:20070922T181002Z
DTSTAMP:20070922T181509Z
UID:1f91629f-0942-4c7c-93e1-43a694306ce5
SUMMARY:National Woman's Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080809
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080810
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T181043Z
LAST-MODIFIED:20070922T181101Z
DTSTAMP:20070922T181509Z
UID:d49f2ed6-45a4-45e5-85eb-38de7d61e088
SUMMARY:Heritage Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080924
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080925
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T181118Z
LAST-MODIFIED:20070922T181147Z
DTSTAMP:20070922T181509Z
UID:cdd33c9b-bd98-4585-8156-eb34d3f93ee1
SUMMARY:Day of Reconciliation
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20081216
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20081217
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T181202Z
LAST-MODIFIED:20070922T181222Z
DTSTAMP:20070922T181509Z
UID:298a2141-44ee-4494-96e2-084bed1e202b
SUMMARY:Public Holiday
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20081217
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20081218
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T181228Z
LAST-MODIFIED:20070922T181244Z
DTSTAMP:20070922T181509Z
UID:099b62fa-b6d4-44c3-baa5-677d12317b8d
SUMMARY:Christmas Day
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20081225
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20081226
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T181249Z
LAST-MODIFIED:20070922T181307Z
DTSTAMP:20070922T181509Z
UID:36665be0-527b-457e-a9fc-33b910734986
SUMMARY:Day of Goodwll
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20081226
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20081227
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T180541Z
LAST-MODIFIED:20070922T180612Z
DTSTAMP:20070922T181509Z
UID:a5313061-6e5d-4d92-9da0-8c79581e63b5
SUMMARY:Good Friday
RRULE:FREQ=YEARLY;INTERVAL=1
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080406
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080407
CATEGORIES:Holidays
END:VEVENT
BEGIN:VEVENT
CREATED:20070922T181407Z
LAST-MODIFIED:20070922T181407Z
DTSTAMP:20070922T181509Z
UID:a5313061-6e5d-4d92-9da0-8c79581e63b5
SUMMARY:Good Friday
RECURRENCE-ID;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080406T000000
DTSTART;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:
 20080404
DTEND;VALUE=DATE;TZID=/mozilla.org/20070129_1/Africa/Johannesburg:20080405
END:VEVENT
END:VCALENDAR


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Attached file South African Holidays Calander (obsolete) —
Your attention is drawn to the Public Holidays Act of 1994, which provides that if any holiday should fall on a Sunday, the following  Monday will be a public holiday.
File added to holiday page. Thanks for your contribution.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Attached file South African Holidays - 2008 (obsolete) —
Update 2008
New holiday ICS file attached. -> REOPENING
Status: VERIFIED → UNCONFIRMED
OS: Windows Vista → All
Hardware: PC → All
Resolution: FIXED → ---
Assignee: nobody → ralph
Status: UNCONFIRMED → NEW
Ever confirmed: true
File added to holiday page. Thanks for your contribution.

-> FIXED
Status: NEW → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Hi Ralph,
any interest in updating the calendar holiday file with the 2009 and (if it's
possible) the 2010 holidays of South Africa?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Attached file Public Holidays 2009 (obsolete) —
Attachment #281955 - Attachment is obsolete: true
Attachment #295065 - Attachment is obsolete: true
Attachment #355383 - Attachment mime type: text/calendar → text/plain
Thanks for the update. File checked in.

I would appreciate it, if you could set a reminder for yourself to update this holiday calendar file in time for 2010.
Status: NEW → RESOLVED
Closed: 12 years ago11 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Summary: South African Holidays → South African Holidays 2008-2009
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Attached file Public Holidays - South Africa 2010 (obsolete) —
Summary: South African Holidays 2008-2009 → South African Holidays 2010
Committed revision 58143 to SVN.

Thanks for your contribution.

--> FIXED
Status: REOPENED → RESOLVED
Closed: 11 years ago10 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Attachment #355383 - Attachment is obsolete: true
Attachment #416315 - Attachment is obsolete: true
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Thanks a lot for your contribution, Ralph, but unfortunately, Malcolm McLean already provided us a calendar file for 2012-2015 in Bug 728667.
Status: REOPENED → RESOLVED
Closed: 10 years ago7 years ago
Resolution: --- → DUPLICATE
Summary: South African Holidays 2010 → South African Holidays 2013
Duplicate of bug: 728667
You need to log in before you can comment on or make changes to this bug.