bmo bugmail puts seemingly random newlines in subject line

RESOLVED DUPLICATE of bug 374424

Status

()

Bugzilla
Email Notifications
RESOLVED DUPLICATE of bug 374424
11 years ago
4 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Unassigned)

Tracking

3.0.1
x86
Windows XP

Details

For some time now, emails from b.m.o about updates to bugs seem to contain 
one or more newlines in strange places, places where they don't belong.  
These newline characters are not present in the actual bug database subject 
entry.  They are inserted in the course of making the email.  They don't 
affect every bug, but the bugs that are affected are affected consistently 
(every email for those bugs has the problem). Here are some examples:

1. two unneeded newlines
Subject: [Bug 397405]
   Should be able to change the interval for which cert chain is present in
 cache

2. two unneeded newlines 
Subject: [Bug 397405] New:
   Should be able to change the interval for which cert chain is present in
 cache

3. newline in the middle of a file name
Subject: [Bug 397122] NSS 3.12 alpha treats a key3.
  db with no global salt as having no password

4. two unneeded newlines, one in the middle of a URL
Subject: [Bug 397178] Crash when entering
 chrome://pippki/content/resetpassword.
  xul in URL bar

5. in a review email, but in a different place in the associated normal bug 
mail, e.g. 

Subject: review granted: [Bug 254987]
   Continuation and TimerManager threads survive PR_Cleanup

Subject: [Bug 254987] Continuation and TimerManager threads survive
 PR_Cleanup

6. newline in the middle of a symbolic name
Subject: review granted: [Bug 334285] PR_REALLOC is missused in [@
   ExpandMonitorCache]

7. 
Subject: [Bug 383229]
   Password Manager should honor the master password timeout prefs

8. two unneeded newlines, one in the middle of a release number.
Subject: [Bug 397122] NSS 3.12 alpha sees no keys in key3.db that works OK
 with 3.11
  .x

9. bizarre single-character line
Subject: [Bug 327181] Improve error reporting for invalid-certificate errors
 (
  error page for https, or combined dialog)

10. The above example changed when the subject was edited:
Subject: [Bug 327181] Use error pages for https invalid-certificate errors (
 instead of dialogs)
This is a dupe.  Don't have the number handy.  It's an upstream bug in the Email:: modules I believe.  Original bug is in the Bugzilla product.
Whiteboard: DUPEME
Assignee: justdave → email-notifications
Component: Bugzilla: Other b.m.o Issues → Email Notifications
Product: mozilla.org → Bugzilla
QA Contact: reed → default-qa
Version: other → 3.0.1
(Reporter)

Comment 2

11 years ago
The problem is made worse, and more apparent, by the insertion of more than
one blank character at the beginning of the split line(s).

Subject: [Bug 397405]
   Should be able to change the interval for which cert chain is present in
 cache

Subject: [Bug 294531]
   Design new interfaces for certificate path building and verification for
 libPKIX

Thunderbird eats the newline and ONE space, but the extra spaces really 
stick out.  The above lines appear as

                      v- very apparent
Subject: [Bug 397405]  Should be able to change the interval for which cert 
Subject: [Bug 294531]  Design new interfaces for certificate path building 
                      ^- very apparent

This behavior (odd newlines seems to have begun in June, but the additional
space characters began just in the last week or 2 (or 3).  
It seems to have suddently gotten MUCH worse today.  

Comment 3

11 years ago
This problem is actively discussed in bug 374424. It seems that several characters cause newlines to appear.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 374424

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.