Closed Bug 397462 Opened 14 years ago Closed 14 years ago

IFrames does not paint content after an height of over 32768px

Categories

(Firefox :: General, defect)

x86
Windows Vista
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 333994

People

(Reporter: sid, Unassigned)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SU 3.005; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; InfoPath.2)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

When setting an height of over 32768 pixels to an iframe content of the iframe that is over this limit is not painted and stops sharp at 32768 even though the "outer" height of the iframe is properly sized. The only way to see the rest of the content is to activate the scrolling property on the iframe. 

Note : If size is bigger than 32768 and scrolling is enable "outer" size will still match the proper size while auto scroll will limit itself up to 32768 (which is certainly related to the issue of non paiting over 32768)

Reproducible: Always

Steps to Reproduce:
1.Create a standard iframe
2.Set the pixel height to over 32768 eg: 40000
3.Put content that would be over 32768 pixel height, a picture is fine as these get cut as well.
Actual Results:  
area over the height of 32768 pixels doesnt get painted

Expected Results:  
show the whole size painted without having to add a scrollbar. This works in IE for example
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
You need to log in before you can comment on or make changes to this bug.