Last Comment Bug 333994 - Firefox uses signed 16 bit integer for IFRAME height (Content is clipped - not rendered/shown beyond 32767px) [32768]
: Firefox uses signed 16 bit integer for IFRAME height (Content is clipped - no...
Status: RESOLVED FIXED
: testcase
Product: Core
Classification: Components
Component: Layout: HTML Frames (show other bugs)
: Trunk
: All All
: -- normal with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 384614 397462 403759 440879 503941 564836 (view as bug list)
Depends on: big-long-large-32767
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 07:37 PDT by Alex
Modified: 2010-05-10 15:47 PDT (History)
17 users (show)
samuel.sidler+old: wanted1.9.0.x-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
master.html (192 bytes, text/html)
2006-04-14 07:38 PDT, Alex
no flags Details
child.html (98.29 KB, text/html)
2006-04-14 07:40 PDT, Alex
no flags Details
master.html (189 bytes, text/html)
2006-04-14 07:48 PDT, Alex
no flags Details
Minimal testcase: signed integers used for iframe height (and width?) (1.07 KB, text/html)
2008-08-18 11:16 PDT, Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m)
no flags Details

Description Alex 2006-04-14 07:37:23 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; fr) AppleWebKit/417.9 (KHTML, like Gecko) Safari/417.8
Build Identifier: Iframe max height of 32767 pixels !

Master page :
master.html
<html>
<head></head>
<body>
	<iframe id="anId" name="aName" width="100%" height="32768px" src="child.html" scrolling="no" frameborder="0"></iframe>
</body>
</html>

Child page (note: write 11000 lines into <body></body>, thanks copy/paste ;) ) :
child.html
<html>
<head></head>
<body>
line 1<br/>
line 2<br/>
....
line 11000<br/>
</body>
</html>

When you load master.html ( child.html must be into the same directory ), the content iframe is blast
However, with a 32767px height, the content will be shown. Sometimes it will freeze after be displayed


Somebody have an Idea ?

Thanks 





Reproducible: Always

Actual Results:  
The content iframe is blast


When the iframe is into a DIV, the iframe height is 100% and the DIV height is increased to 32768 ( in Javascript ) the problem is identical.
Comment 1 Alex 2006-04-14 07:38:44 PDT
Created attachment 218423 [details]
master.html

the file to launch
Comment 2 Alex 2006-04-14 07:40:44 PDT
Created attachment 218424 [details]
child.html
Comment 3 Alex 2006-04-14 07:48:57 PDT
Created attachment 218426 [details]
master.html

the file to launch
Comment 4 Jesse Ruderman 2006-04-19 01:02:35 PDT
See also bug 334405, "iframe about 32768px (2^15 px) from top of page makes Firefox stop painting"
Comment 5 Mihai Bazon 2006-06-27 03:56:35 PDT
I put a testcase here too: http://www.bazon.net/bugs/iframe-bug.html

There's an IFRAME embedded in a DIV.  After the IFRAME content was loaded, the IFRAME is resized to sufficient dimensions to display the full content without scroll-bars; the final size is alert()-ed.  The scroll mechanism is provided by the parent DIV.  If you scroll down around line 2183, you will notice that anything after it is blank (exceeds 32768 pixels).

This happens in Firefox/Windows; works fine with Firefox/Linux.  I haven't tested on the Mac.

This bug can seriously affect Zimbra (messages that display on more than 32768 pixels will look like that).  Any fix planned?
Comment 6 wtallis 2007-03-25 19:06:25 PDT
Confirmed on OS X 10.4.9. 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a3) Gecko/20070322 GranParadiso/3.0a3
Comment 7 Adam Guthrie 2007-05-17 16:20:48 PDT

*** This bug has been marked as a duplicate of bug 215055 ***
Comment 8 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-08-18 11:16:03 PDT
Created attachment 334317 [details]
Minimal testcase: signed integers used for iframe height (and width?)

I reopen this bug because it's not exactly a duplicate of Bug 215055, as I wrote in Bug 440879 Comment 4:

  See the attached testcase: Bug 215055 is about elements with 
  overflow!=visible. Furthermore for iframes seems Fx uses signed integers, 
  while for divs it uses unsigned. So a part of this bug seems simple to fix. 
  The other part (iframe can't be taller than 16 bit) is probably related to 
  Bug 215055.
Comment 9 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-08-18 11:27:03 PDT
*** Bug 440879 has been marked as a duplicate of this bug. ***
Comment 10 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-08-18 11:28:44 PDT
*** Bug 403759 has been marked as a duplicate of this bug. ***
Comment 11 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-08-18 11:30:14 PDT
*** Bug 384614 has been marked as a duplicate of this bug. ***
Comment 12 Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m) 2008-08-18 11:30:43 PDT
*** Bug 397462 has been marked as a duplicate of this bug. ***
Comment 13 Daniel Veditz [:dveditz] 2008-08-29 11:25:33 PDT
Not a blocker for security releases, if there's a trunk fix we can evaluate it for shipping on the stable branches after that.
Comment 14 Samuel Sidler (old account; do not CC) 2008-12-17 10:59:58 PST
Actually, this not really wanted. If you want it fixed, we should get it in 1.9.1 or 1.9.2.
Comment 15 Timothy Nikkel (:tnikkel) 2009-07-14 12:50:33 PDT
*** Bug 503941 has been marked as a duplicate of this bug. ***
Comment 16 j.j. 2009-07-23 18:39:43 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090722 Minefield/3.6a1pre

Fixed by bug 352093 in 1.9.2 trunk (not in Fx 3.5.x).
Used testcase of bug 503941 to verify this.
Comment 17 Ryan VanderMeulen [:RyanVM] 2010-05-10 15:47:41 PDT
*** Bug 564836 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.