Closed Bug 398072 Opened 13 years ago Closed 13 years ago

Junk will not automatically delete (or move to Junk folder)

Categories

(Thunderbird :: Preferences, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 279018

People

(Reporter: fbechter, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 

In my version of Thunderbird three or four months ago, if I marked an email as Junk, it would immediately move to the Junk folder, which is exactly what I would want. As far as I can tell now, only mail that is originally filtered as Junk goes to that folder. Anything that I mark as Junk in my Inbox stays there until I delete it, or until I, laboriously, go up under tools and select "Delete email marked as Junk in folder." If I go to Tools/AccountSettings/JunkSettings, there is no option to select for Junk mail to be moved to the Junk folder immediately upon designating it as such. Surely this would be an improvement, no? At the very least, it would be nice if Junk could be moved from a folder upon exiting. Sorry to report this here, but your website seems to have no feedback option. And, for all I know, perhaps this is a bug. I.e., perhaps items marked as Junk are supposed to move automatically. If so, they are not. 

Reproducible: Always

Steps to Reproduce:
1. Mark an email as Junk.
2. Look at it sitting forever in your inbox until you take the additional step of deleting it.
3. Look for option under Tools/AccountSettings/JunkSettings for mail marked as Junk to be automatically deleted or moved to Junk folder, and find that there is no such option.



Again, in a previous version of Thunderbird (three or four months ago), mail marked as Junk would automatically be moved to the Junk folder upon marking it (provided this option was selected). There seems to be no such option now.
This should be bug 279018, fixed for tb2.0.0.8.

The option you ask for is under Options > Privacy > Junk
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 279018
You need to log in before you can comment on or make changes to this bug.