Closed Bug 398138 Opened 13 years ago Closed 11 years ago

SM2: New ftp listing style missing in modern theme

Categories

(SeaMonkey :: Themes, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0b1

People

(Reporter: bugzilla.spam2, Assigned: prometeo.bugs)

References

Details

(Keywords: modern)

Attachments

(6 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9a9pre) Gecko/2007092904 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9a9pre) Gecko/2007092904 SeaMonkey/2.0a1pre

The new style for ftp listings is visible in classic theme but missing in modern theme (SeaMonkey 2 trunk).

Reproducible: Always
Blocks: 382795
Attached image Modern Theme Screenshot
We also need a Modern "up to higher folder" icon.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Whiteboard: [good first bug]
Assignee: general → nobody
Component: General → Themes
QA Contact: general → themes
(In reply to comment #4)
> We also need a Modern "up to higher folder" icon.

Can't we just go with a copy of the Classic one, at least for starters?
Duplicate of this bug: 483728
This is from Kudens modern update
Attachment #373143 - Flags: review?(neil)
Comment on attachment 373143 [details] [diff] [review]
Patch v1.0 From Kudens modern update .jar

>diff --git a/suite/themes/modern/global/dirListing/dirListing.css b/suite/themes/modern/global/dirListing/dirListing.css
>new file mode 100644
But no jar.mn entry...

>+ * Dao Gottwald <dao@design-noir.de>.
D<funny character>o

>+:root {
>+  background-color: #C7D0D9;
Wrong colours. See netError.css or even my previous attachment (but note that it has some errors too.)

>+  margin: 0 0 0.6em;
.6em apparently ;-)

>+  border-bottom: 1px solid #90A1B3;
For some reason my file had a different colour, although offhand I don't know where I got it from.

>+#UI_goUp {
>+  margin-top: 0;
>+  float: left;
>+}
>+
>+#UI_showHidden {
>+  margin-top: 0;
>+  float: right;
>+}
Could use the RTL fixes.

>+  border-collapse: collapse;
But there are no borders...

>+tbody > tr:hover > td {
>+  background-color: #F3F3F3;
Strange. Shouldn't there be an outline instead?

>+  content: url("chrome://global/skin/dirListing/up.png");
I've discovered that we don't need a new image for this - we already use one for the Linux filepicker.

>+  content: url("chrome://global/skin/dirListing/folder.png");
And this is the same as the bookmark folder image, so you might as wel reuse that too.
Attachment #373143 - Flags: review?(neil) → review-
Blocks: 456757, 465924
OS: Windows XP → All
Attachment #376729 - Flags: review?(neil)
Comment on attachment 376729 [details] [diff] [review]
A first attempt at fixing Neil's review comments

>+h1 {
>+  font-size: 160%;
>+  color: #4F6C8B;
Where does this colour come from?

>+tbody > tr:hover > td {
>+  background-color: #8C99AB;
I didn't get an answer about this when I asked last time...

>+  skin/modern/global/dirListing/local.png                          (global/dirListing/local.png)
>+  skin/modern/global/dirListing/remote.png                         (global/dirListing/remote.png)
These were originally added to *stripe as favicons. Unfortunately chrome favicons aren't available from content documents, so they got changed to data: URLs and so these are no longer necessary.
Attachment #376927 - Flags: review?(neil) → review+
Neil gave me a r+sr on irc.
Time for someone else to check this in! (and no, I can't modify whiteboard nor keywords)
Assignee: nobody → prometeo.bugs
Severity: trivial → enhancement
Status: NEW → ASSIGNED
Hardware: x86 → All
Attachment #373143 - Attachment is obsolete: true
Comment on attachment 376927 [details] [diff] [review]
Removed useless files, changed color for h1 and added an outline for tr to match *stripe (the color comes from checkbox:focus in modern/checkbox.css)
[Checkin: Comment 14]


http://hg.mozilla.org/comm-central/rev/61c769c3dd7b
Attachment #376927 - Attachment description: Removed useless files, changed color for h1 and added an outline for tr to match *stripe (the color comes from checkbox:focus in modern/checkbox.css) → Removed useless files, changed color for h1 and added an outline for tr to match *stripe (the color comes from checkbox:focus in modern/checkbox.css) [Checkin: Comment 14]
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [good first bug]
Target Milestone: --- → seamonkey2.0b1
SeaMonkey trunk build 20090620
The new style for ftp listings is still not visible, see attached screenshot. Furthermore the new style is also gone in classic theme.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #384275 - Attachment description: old ftp listing → still old ftp listing after checkin
(In reply to comment #16)
> SeaMonkey trunk build 20090620
> The new style for ftp listings is still not visible, see attached screenshot.
> Furthermore the new style is also gone in classic theme.

Please retry in Safe Mode and/or a fresh profile. I'm using a 20090621 nightly on WinXP and can't reproduce your problem. Maybe one of your extensions is interfering or it's a platform problem (which are you using?) or the new styling is controlled by a pref (didn't check).
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9.1pre) Gecko/20090621 SeaMonkey/2.0b1pre

1. Safe mode/classic. WFM. (The theme is hard coded to classic in safe mode)
2. Modern also WFM.

What's your OS?
In safe-mode there is also the classic view used. With a new profile I get the new ftp listing. I tried to disable user*.css but this did not help.

I just checked the ftp listings in DOM inspector. With a new profile dirListing.css is called for ftp listings. With my old profile dirListing.css does not appear in DOM inspector.
I use Windows XP with Luna enabled. I just deleted the xul-cache but no changes.
OK. My fault. 
The external proxy I use somehow prevents SeaMonkey from recognizing that I am on a ftp site. And in this case SeaMonkey shows the normal http listing for the ftp directory. So this bug is fixed.
Sorry for the confusion.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.