Closed Bug 398341 Opened 14 years ago Closed 14 years ago

Javascript Scrollbar displays when it should be hidden on Mac OS X only

Categories

(Firefox :: General, defect)

2.0 Branch
PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 187435

People

(Reporter: Matthew.L.Henderson, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

Dynamic content using javascript scrollbars appears when it shouldn't.

The only workaround is to force the content in the area where the scrollbar *shouldn't* be to be large enough to cover the area where the scrollbar is defined.  In that case the scrollbar will be "hidden", but in all other cases it displays in the page.

There is a similar problem for Camino.

The content appears correctly with the same Firefox version on Linux and Windows platforms, and displays well in Safari Version 2.0.4 (419.3).  It also works on the current trunk build {Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007100204 Minefield/3.0a9pre}.  Assuming this is not due to a major code change, a backport of the bugfix should be possible.

Reproducible: Always

Steps to Reproduce:
1.Using Mac OS X Firefox, visit http://navp.ics.uci.edu/~pan/test/choose_form.html

Actual Results:  
The scrollbar for the fourth radio button selection is always shown.

Expected Results:  
The scrollbar should only appear when the fourth radio button is selected.
Version: unspecified → 2.0 Branch
This works fine on trunk.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187435
You need to log in before you can comment on or make changes to this bug.