Closed Bug 398377 Opened 12 years ago Closed 12 years ago

Compose window blank on clicking Reply

Categories

(Thunderbird :: Message Compose Window, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 307672

People

(Reporter: stuart, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: version 1.5.0.13 (20070809)

2 - 4 times a week, if I click on Reply (or reply all or Forward) to a IMAP email I'm reading, the composite window pops up with all its fields disabled apart from the From: field.

If this bug appears, then even clicking on a email link inside the viewed email causes a disabled composite window. 
Closing this disabled window and reopening it does not clear the bug.

Note: whilst the subject line does have the correct content, it is shaded and uneditable. But the To: field is blank and also greyed out.
 

Reproducible: Sometimes

Steps to Reproduce:
I am unable to reproduce it on demand.
I have to restart TB to clear the bug.
Sometimes several times is required for the bug to go away.
Actual Results:  
I'm a heavy imap user, I've 30 folders in my inbox.


Expected Results:  
After I restart TB, and reclick on the Reply button I am able to write an email.


I get this error from the Console when I click on the Reply icon:

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgCompose.initEditor]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/messengercompose/MsgComposeCommands.js :: InitEditor :: line 3499"  data: no]
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 3499

When I close the disabled composite window I get this error:

Error: gMsgCompose.editor has no properties
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 148


I've tried compacting all my folders.
I've noticed that when I reply to a long (> 100KB) text email then the compose window briefly shows this same disabled view until it has finished building the quoted email and it then enables the view. 

So perhaps TB disables the Compose view until it thinks the imap server has finished sending data to it? If so, then if this 'finished' flag is not reset correctly then perhaps this is why it breaks sometimes?
possibly dupe of bug 307672
Version: unspecified → 1.5
Summary: Composite window blank on clicking Reply → Compose window blank on clicking Reply
I think it is Wayne. 

Today I got the bug rearing its ugly head and as per bug 307672 comment #13, I hit the reply button again quickly when I saw it appear.
The result was the compose window refreshed and became editable!

So at least this appears to be a work around.

Should I mention my bug in bug 307672 as they're not talking about Thunderbird?




Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307672
You need to log in before you can comment on or make changes to this bug.