View -> Toolbars -> customize result in JS nsIAnnotationService.addObserver Errors

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: cbook, Unassigned)

Tracking

Trunk
Firefox 3 beta3
x86
All
Points:
---
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a9pre) Gecko/2007100304 Minefield/3.0a9pre ID:2007100304

When you click on View -> Toolbars -> Customize you get:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.addObserver]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/toolbar.xml :: _init :: line 78"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.addObserver]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/toolbar.xml :: _init :: line 78"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.addObserver]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/toolbar.xml :: _init :: line 78"  data: no]

Reproduced on Mac and Windows. 

Not sure if this is related to places, cc dietrich and seth to this bug.
Flags: in-litmus?
Flags: blocking-firefox3?
Probably the same bug as bug 398346.
Blocking, although hopefully it's just a dupe of an already known blocker.
Flags: blocking-firefox3? → blocking-firefox3+
I have a feeling that this bug is related to Bug 398346. When that fix lands we just need to give toolbar customize a robust workout.
Looks like WFM now... Marcia/Tomcat please confirm.
Target Milestone: --- → Firefox 3 Mx
(In reply to comment #4)
> Looks like WFM now... Marcia/Tomcat please confirm.
> 

confirmed works for me with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b1) Gecko/2007110703 Firefox/3.0b1

Also added as testcase to litmus.
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-litmus?
Flags: in-litmus+
Flags: blocking-firefox3+
Resolution: --- → WORKSFORME
Target Milestone: Firefox 3 Mx → Firefox 3 M11
You need to log in before you can comment on or make changes to this bug.