If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Opening/closing toolbar customize breaks the location bar

VERIFIED FIXED

Status

()

Firefox
Address Bar
--
blocker
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007100204 Minefield/3.0a9pre.

STR:
1. Working on it. Have now seen it twice. See URL For screenshot.

Both times it happened I ended up getting Firefox in a state where it would I could not enter a URL, and then when I entered the URL it put it on top of the one that was not cleared out. In the screen shot you can the fijiwater.com website underneath the mozilla.org entry.

I saw this error in the console: Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMNSHTMLInputElement.setSelectionRange]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/textbox.xml :: onxblmousedown :: line 184" data: no]

Comment 1

10 years ago
Removing the search bar is 100% way to reproduce this.  Fixes itself after closing the window or restarting firefox.

also these errors:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.addObserver]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/toolbar.xml :: _init :: line 78"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIAnnotationService.addObserver]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/toolbar.xml :: _init :: line 78"  data: no]

Error: this.editor has no properties
Source File: chrome://global/content/bindings/textbox.xml
Line: 124

Posting my message from mozillazine since there is more brokeness other than just garbled text.

"when I click on it the address disappears, i type in there some stuff and clicked back on the page, the address was then on top of the text i wrote in the location bar?! I open a blank tab and the text behind the address shows up in all of the new tabs location bars changing the text in one changes it in all at the same time...weird. Also hitting enter to go to an address does nothing."
Severity: normal → blocker
Flags: blocking-firefox3?
OS: Mac OS X → All
Summary: Garbled URLs in location bar → Removing the search bar breaks the location bar

Comment 2

10 years ago
Sorry I copied one of the same errors twice.  Here is the other one that I meant to post:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMNSHTMLInputElement.selectionStart]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/textbox.xml :: onxblclick :: line 192"  data: no]

Updated

10 years ago
Summary: Removing the search bar breaks the location bar → Opening/closing toolbar customize breaks the location bar

Comment 3

10 years ago
I always play around with stuff for a while, post a message when I think I have all information and then I find out more afterwards. sorry

Actually just opening and closing the customize dialog breaks the location bar. No need to remove the search bar.
Created attachment 283380 [details]
screenshot of problem

Updated

10 years ago
Hardware: PC → All

Updated

10 years ago
Duplicate of this bug: 398416
Flags: blocking-firefox3? → blocking-firefox3+

Comment 6

10 years ago
This broke with bug 372769.

Updated

10 years ago
Duplicate of this bug: 398096

Updated

10 years ago
Blocks: 372769
The fix for bug 398135 will fix this.
Depends on: 398135
Blocks: 398569

Comment 9

10 years ago
This also breaks a few other areas after attempting to customize:
- The URL will disappear if you mousehover the location bar
- the 'Go' button in location bar doesnt work

My guess its all related to the same regression.  fixing this issue, will hopefully fix the rest.
Duplicate of this bug: 399685

Updated

10 years ago
Duplicate of this bug: 400397

Updated

10 years ago
Blocks: 400388

Comment 12

10 years ago
This also breaks the Bookmarks Toolbar overflow, as seen here:
http://img152.imageshack.us/img152/7303/brokenbookmarkstoolbarok7.jpg
Please retest in tomorrow's builds?

Comment 14

10 years ago
Bug was solved with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007102005 Minefield/3.0a9pre

Comment 15

10 years ago
Verified fixed with Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a9pre) Gecko/2007102004 Minefield/3.0a9pre

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Verified FIXED using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007111704 Minefield/3.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.