Last Comment Bug 398617 - Crash when adding a calendar Event.
: Crash when adding a calendar Event.
Status: VERIFIED INVALID
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: unspecified
: All All
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 15:08 PDT by Adam Moore
Modified: 2008-02-21 01:42 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Adam Moore 2007-10-04 15:08:34 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: 0.7rc1

If I add an event from the Main calendar window or the calendar sidebar it crashes Thunderbird.  I use TB 2.0.6 and Lightning 0.7rc1 on Win XP.  I don't remember for sure, but I think I had a development build of 0.7, before this and it worked fine from the main window.

Reproducible: Always

Steps to Reproduce:
1.Create a new Event
2.Save it.
Actual Results:  
Hard crash that closes TB

Expected Results:  
Create an event.
Comment 1 Andreas Treumann 2007-10-04 23:30:09 PDT
I checked this issue and I get no crash. Which kind of calendar do you use (local/network)? And how do you create the event (drag&drop, via menu)?

Could you reproduce this bug with a fresh profile?

Please give further information and a detailed step-by-step description.  
Comment 2 Omar Bajraszewski 2007-10-05 00:47:11 PDT
I'm using 0.7 RC1 at the moment and didn't notice any crash. And I create events every day.
Comment 3 Adam Moore 2007-10-05 08:15:30 PDT
I looked at trying to reset my profile, but I couldn't figure out how I go about getting a fresh profile without losing the email I currently have.

I create an event either by going to the right side bar and double clicking on Today, going to the main calendar window and right clicking and choose create event, or editing an event. Enter the event information.  And as soon as I click save and close it crashes.  

Testing it some more now it will still create the event after I reopen thunderbird.  

Windows crash report has this information. 

AppName: thunderbird.exe	 AppVer: 1.8.20070.7281	 ModName: xpcom_core.dll
ModVer: 1.8.20070.7281	 Offset: 0003ffba

Unfortunately I can't figure out how to copy the full crash report or I would attach it.
Comment 4 Adam Moore 2007-10-05 08:27:12 PDT
Found the issue.  I had the Funambol plugin installed and disabling this fixed the crashing issue.  Will report to Funambol.

Thank you for the help.
Comment 5 Stefan Sitter 2007-10-05 09:32:55 PDT
See similar Bug 384850. The Funambol PlugIn 0.3.1 crashed Thunderbird + Lightning 0.5 release. A new release of the Funambol plugin fixed this. For Lightning 0.7 there is probably the same issue and a new release of the Funambol plugin is required.

Do you send any Talkback Crash report back to the Mozilla servers?
Comment 6 Adam Moore 2007-10-05 10:44:35 PDT
It didn't offer a talkback crash report.  Only an MS crash report.  I was using 0.3.2 which did work on 0.5.  I am assuming it is the same issue.  I hadn't used the funambol plugin in months, because it wasn't working, and had forgot about it being installed.
Comment 7 Stefan Sitter 2007-10-17 10:13:21 PDT
Adam, does Lightning works after disabling/uninstalling the Funambol PlugIn extension?
Comment 8 Adam Moore 2007-10-17 21:04:52 PDT
Yes as soon as it was disabled and Thunderbird was restarted the bug did not occur.
Comment 9 Stefan Sitter 2007-10-19 01:11:19 PDT
Resolving INVALID per Comment #8 because the crash caused by the Funambol PlugIn extension.

Simon, I think it's worth to add this information to the release notes. We had the same issue with Lightning 0.5 until a new release of the Funambol PlugIn extension was available.
Comment 10 Simon Paquet [:sipaq] 2007-10-19 02:00:54 PDT
Added to release notes.

Note You need to log in before you can comment on or make changes to this bug.