If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

modal "open dialog" (browse) breaks toolbar UI and other stuff

RESOLVED DUPLICATE of bug 257121

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 257121
10 years ago
10 years ago

People

(Reporter: martin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.7) Gecko/20070914 Firefox/2.0.0.7

1. open this URL in Firefox (version 2.0.0.7):
http://commons.wikimedia.org/w/index.php?title=Special:Upload&uselang=ownwork

2. Scroll down just a tad to find the BROWSE button (where you select an image to upload)

3. Press it (now a model "open dialog" appears). Model in this context means that the current browser window can't be used until the "open dialog" is either completed or canceled (for instance, you can open the File/Edit/View menus while the "open dialog" is open. this "modal" behavior is perfectly normal.

4. Now, launch Firefox again (I do this by clicking the icon in my windows "quicklaunch" toolbar next to the start menu). The problem also repros for me when I use START::RUN to launch "C:\Program Files\Mozilla Firefox\firefox.exe"

5. A new Firefox window appears, it's kind of working as normal expect some small details. For instance the toolbar that sits right now under "back", "forwards" etc will be empty. If you right click the empty toolbar area a small 2x2 mm gray box appears instead of a proper context menu.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 283919 [details]
firefox showing quick launch icon and what I call the "bookmark toolbar"
(Reporter)

Comment 2

10 years ago
Created attachment 283920 [details]
firefox showing the browse button and the modal "open dialog"
(Reporter)

Comment 3

10 years ago
Created attachment 283921 [details]
firefox showing the bug itself: a broken bookmark toolbar and a broken context menu
(Reporter)

Comment 4

10 years ago
I see this behavior on Win2K and I suspect it will repro on WinXP and Vista too. I did however try it on Ubuntu Gutsy BETA1 and on that platform all behavior is correct (bug does NOT repro on Linux).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 257121
You need to log in before you can comment on or make changes to this bug.