toolbars (including bookmarks toolbar) are not loaded, url bar not filled, changing tabs / scrolling doesn't work in a new window when the save as/open/upload dialog (file picker) is open

RESOLVED FIXED in mozilla1.9beta4

Status

()

Core
Widget: Win32
--
minor
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

Trunk
mozilla1.9beta4
x86
Windows XP
Points:
---
Bug Flags:
blocking1.8.1 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040614 Firefox/0.9

Opening a new firefox windows (A) Mouse don't scroll anymore and (B) bookmarks
toolbar is no more loaded when starting to download a file in another window

Reproducible: Always
Steps to Reproduce:
1.Try to download any file
2.Save to Disk => OK (You must have the possibility to select the "Ask me where
to save any files" options in the firefox configuration)
3.Let's open the "save as" window.
4.Open a new firefox process (not a new tab but a new window)
5.Bookmarks Toolbar will not load, but will leave an empty space.
6.Mouse will not scroll anymore.
7.Just start downloading the file (no "save as" window open) and all problems go
away


Actual Results:  
No mouse scroll and no bookmarks toolbar loaded.

Expected Results:  
The mouse have to scroll and bookmarks toolbar has to be displayed
For me, a new window will not open until I close the "Save as..." box. How do
you open the second window?
(Reporter)

Comment 2

14 years ago
I click on the icon!
With new window i mean a new process, not a new tab in the current window
There is no way as far as I know to open more than one process of Firefox in
Windows. Trying to start a new process results in the creation of a new window
in the same process. A process can contain many windows, just because it is a
new window does not mean it is a new process.

Back on topic here, I should have probably said it clearer, but for me, it is
impossible to open a new window when the Save as... dialog box is active.
Clicking the icon again does nothing for me until I close the Save As... dialog.
(Reporter)

Comment 4

14 years ago
Ok u are right, no more processes.. my fault.
I just replicated the problem...
the download must be automatic, i mean you don't have to right click and choose
"save link as" but the "save" window has to come automatically (es. with
clicking on a .exe file).
After that go to "save as" and you can open another window with the toolbar problem!
Ok, that I can reproduce. Confirming since I can't find a dupe. Bug 234560
contains some more Save As... dialog wierdness but I don't think it's related.
Status: UNCONFIRMED → NEW
Component: Toolbars → Download Manager
Ever confirmed: true
*** Bug 265555 has been marked as a duplicate of this bug. ***
Severity: normal → minor
Summary: bookmarks toolbar is not loaded in a new fifox window when downloading a file in another firefox window → toolbars are not loaded in a new window when the "save as" or "file upload" dialog is open
Version: unspecified → 1.0 Branch

Comment 7

14 years ago
For me steps to reproduce are simply:
1. CTRL+O (File>Open)
2. Click the firefox shortcut to open a new window

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041106 Firefox/1.0

Also, autocomplete doesn't work for me in the new window.

Comment 8

14 years ago
*** Bug 268197 has been marked as a duplicate of this bug. ***
*** Bug 296680 has been marked as a duplicate of this bug. ***
Assignee: bugs → nobody
QA Contact: bugzilla → download.manager
Summary: toolbars are not loaded in a new window when the "save as" or "file upload" dialog is open → toolbars (including bookmarks toolbar) are not loaded in a new window when the "save as" or "file upload" dialog is open
This is very likely a threading issue of Mozilla in windows. 
See http://www.mountaindragon.com/html/marquee.htm
The marquee suddenly stops when you do File->Open File
Firefox uses internally some timers to set the toolbars on it's place. Those
timers don't get fired, because of this issue.
This behavior can also be seen in Mozilla1.0 (marquee stopping when opening
file), so this is not a recent regression.
Related bug: bug 203573
Assignee: nobody → win32
Component: Download Manager → Widget: Win32
Product: Firefox → Core
QA Contact: download.manager → ian
Version: 1.0 Branch → Trunk
Blocks: 261562

Comment 11

13 years ago
*** Bug 298333 has been marked as a duplicate of this bug. ***
*** Bug 266982 has been marked as a duplicate of this bug. ***
*** Bug 251433 has been marked as a duplicate of this bug. ***
*** Bug 306854 has been marked as a duplicate of this bug. ***
*** Bug 313463 has been marked as a duplicate of this bug. ***
Summary: toolbars (including bookmarks toolbar) are not loaded in a new window when the "save as" or "file upload" dialog is open → toolbars (including bookmarks toolbar) are not loaded, url bar not filled, scrolling doesn't work in a new window when the save as/open/upload dialog is open

Updated

13 years ago
Summary: toolbars (including bookmarks toolbar) are not loaded, url bar not filled, scrolling doesn't work in a new window when the save as/open/upload dialog is open → toolbars (including bookmarks toolbar) are not loaded, url bar not filled, scrolling doesn't work in a new window when the save as/open/upload dialog (file picker) is open
*** Bug 313993 has been marked as a duplicate of this bug. ***
*** Bug 310309 has been marked as a duplicate of this bug. ***
Summary: toolbars (including bookmarks toolbar) are not loaded, url bar not filled, scrolling doesn't work in a new window when the save as/open/upload dialog (file picker) is open → toolbars (including bookmarks toolbar) are not loaded, url bar not filled, changing tabs / scrolling doesn't work in a new window when the save as/open/upload dialog (file picker) is open

Comment 18

13 years ago
The above does not work when another window is opened while the previous (or any other instance) has the dialog open.
*** Bug 284530 has been marked as a duplicate of this bug. ***
*** Bug 285154 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Flags: blocking-aviary2?
*** Bug 320561 has been marked as a duplicate of this bug. ***
not a blocker, but if a fix appears we'll look at it.
Flags: blocking-firefox2? → blocking1.8.1-

Comment 23

13 years ago
*** Bug 323356 has been marked as a duplicate of this bug. ***
*** Bug 330342 has been marked as a duplicate of this bug. ***
*** Bug 332039 has been marked as a duplicate of this bug. ***
*** Bug 339095 has been marked as a duplicate of this bug. ***
*** Bug 340425 has been marked as a duplicate of this bug. ***
*** Bug 343493 has been marked as a duplicate of this bug. ***
*** Bug 343711 has been marked as a duplicate of this bug. ***
*** Bug 350192 has been marked as a duplicate of this bug. ***
*** Bug 358964 has been marked as a duplicate of this bug. ***
*** Bug 359710 has been marked as a duplicate of this bug. ***
*** Bug 359726 has been marked as a duplicate of this bug. ***
*** Bug 360068 has been marked as a duplicate of this bug. ***
*** Bug 362652 has been marked as a duplicate of this bug. ***
*** Bug 362751 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Duplicate of this bug: 357136
Duplicate of this bug: 369709

Updated

12 years ago
Duplicate of this bug: 370359
Duplicate of this bug: 373950

Updated

11 years ago
Duplicate of this bug: 283822

Comment 42

11 years ago
I looked into this a little and it's partially caused by bug 338225 (see the commented out XXXdarin code in nsBaseAppShell::NativeEventCallback).

Another issue is that the code at http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/content/html/document/src/nsHTMLDocument.cpp&rev=3.716#1091
sees the JS that called into the file picker on the context stack and thinks it's the page's JS using document.write (which is not the case).

This is solved by pushing a nsnull JSContext onto the stack before opening a modal dialog in nsXULWindow::ShowModal, and indeed the same change in nsFilePicker (along with uncommenting the XXXdarin code mentioned earlier) fixes the problem. Unfortunately that code is quite performance-sensitive, which is the reason that code is commented out.
Depends on: 338225

Updated

11 years ago
Duplicate of this bug: 261562
Duplicate of this bug: 376314
Duplicate of this bug: 272980
Duplicate of this bug: 376752
Duplicate of this bug: 376799

Updated

11 years ago
Duplicate of this bug: 377645
Duplicate of this bug: 389612
Duplicate of this bug: 392267
Duplicate of this bug: 392795
Duplicate of this bug: 398921
Duplicate of this bug: 400932
No longer blocks: 261562
Duplicate of this bug: 261562
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008022702 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

R.Fixed, by bug 389931 (which was a regression of bug 279703).
Not marking duplicate, as the current bug was much older than these two bugs.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 389931
No longer depends on: 338225
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta4
No longer blocks: 389538
Duplicate of this bug: 423650
Duplicate of this bug: 426535
Duplicate of this bug: 432393
Duplicate of this bug: 434337

Comment 60

10 years ago
Also if you have multiply tabs for your homepage, you can't switch between them. Looks a bit like a hang.

Updated

10 years ago
Duplicate of this bug: 436049

Updated

10 years ago
Duplicate of this bug: 443532
You need to log in before you can comment on or make changes to this bug.